"HP Device Manager" deletes other queues (Ubuntu hplip 3.13.9-1)

Bug #1253432 reported by floid on 2013-11-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned

Bug Description

I've finally "solved" the mystery of CUPS queues for my HP printer disappearing on each reboot. It appears the bug is in the "HP Device Manager" component of hplip and affiliated tools, not the Ubuntu/inherited-from-GNOME side of things.

I keep a raw queue configured for some _very_ legacy Windows clients to continue using their native printer drivers with samba, as necessary for things like printing checks etc. with alignments configured a decade ago.

That queue happens to be called "LJ3030" and [if memory serves, because I just let HP Device Manager delete it on me] was pointed at the "hp:/usb/..." device for the printer using the "Generic Raw Queue" PPD.

As long as that queue exists, at every reboot, HP Device Manager will catch and nag via popup that the "LJ3030" queue is using an "invalid PPD".

Here's where it gets interesting:

Whether you tell it to "keep" or "delete"/reconfigure the queue it is complaining about, apparently ALL QUEUES pointed to that device are deleted.

At every boot I've been configuring two other queues via the system-config-printer GUI (usually ending up with names like "hp-LaserJet-3030" for hplip and "Hewlett-Packard-hp-LaserJet-3030 (PS)" for the Postscript PPD) ... and at every reboot they've been mysteriously deleted...

...until I happened to look before responding to the "HP Device Manager" popup, see they were still there, then respond to the Device Manager popup to "keep" the raw queue named "LJ3030" and watch the _other_ two queues disappear. Not expected behavior!

It will also delete the other good queues if you allow it to delete the raw queue.

I'd love to be able to run everything through a single queue as should be right and proper, but when one set of clients needs a raw queue, and Linux/*NIX printing requires quick access to both the hpcups and PostScript options depending which triggers less bugs with a particular document, this doesn't seem to be possible (see https://answers.launchpad.net/hplip/+question/238717 - envelopes only print with hplip/hpcups; multiple page PDFs only print... now by giving up and using a different printer, which is a huge regression).

Any risk of job collision is rare in a 2-seat office, and previously it seemed like something at the "hp:/usb/" layer was serializing jobs properly despite the plethora of queues.

...

So, it turns out the HP Device Manager obliterated my original configuration of queues on upgrade of Ubuntu and hplip, except for the LJ3030 queue, then has been repeatedly obliterating other queues pointed at the device on every boot since. At least it only seems to be removing queues related to the device it is interested in, as queues for other printers and cups-pdf etc remain untouched.

For particular debugging info, just let me know what logs / output would be helpful.

Package: hplip
Status: install ok installed
Priority: optional
Section: utils
Installed-Size: 423
Maintainer: Ubuntu Developers <email address hidden>
Architecture: amd64
Version: 3.13.9-1

Hi Floid,

Generally most of the users facing the problems with multiple queues creation issue and incorrect PPD being selected, to fix this for HP printer are bing configured using hp-tools.
Sorry for the inconvenience caused, we will look into this. Meanwhile, make following changes.

1) take a copy of /usr/share/hplip/config_usb_printer.py file
    $ sudo cp /usr/share/hplip/config_usb_printer.py /usr/share/hplip/config_usb_printer.py_backup

2) open /usr/share/hplip/config_usb_printer.py in root mode
    $ sudo gedit /usr/share/hplip/config_usb_printer.py
          ---> comment cups.delPrinter(printer_name) statement. ( line no appr. 76)
         Change From:
                     cups.delPrinter(printer_name)
         Change To:
                     #cups.delPrinter(printer_name)

3) remove the unwanted queues
    $ hp-setup -r

4) Configure the required print queue

Thanks & Regards,
Amarnath

This fix is released in HPLIP-3.14.3

Changed in hplip:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers