HP OfficeJet G55 doesn't work

Bug #1209339 reported by ender on 2013-08-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Sanjay Kumar

Bug Description

Hello

After the recent Debian dist-upgrade from oldstable (squeeze) to stable (wheezy) my OfficeJet G55 stoped scanning and printing. The cups webinterface shows the message "/usr/lib/cups/backend/hp failed" and in the cups error_log no error is report exept for:
E [07/Aug/2013:13:30:19 +0200] Failed to update TXT record for HP OfficeJet G55 @ qnap.stat.tux: -2
E [07/Aug/2013:13:35:20 +0200] [Job 4] Stopping unresponsive job!

I tried different hplip versions:

hplip_3.13.7 from hplipopensource --> not working
hplip_3.13.4-1 from Debian testing --> not working
hplip_3.12.6-3.1 from Debian stable --> not working
hplip_3.10.6-2 from Debian oldstable --> working
hplip_3.10.6 from hplipopensource --> working

-------------------------------------------------------------------------------------------------
$ lsusb -v -d 03f0:0011

Bus 001 Device 006: ID 03f0:0011 Hewlett-Packard OfficeJet G55
Device Descriptor:
  bLength 18
  bDescriptorType 1
  bcdUSB 1.00
  bDeviceClass 0 (Defined at Interface level)
  bDeviceSubClass 0
  bDeviceProtocol 0
  bMaxPacketSize0 8
  idVendor 0x03f0 Hewlett-Packard
  idProduct 0x0011 OfficeJet G55
  bcdDevice 1.00
  iManufacturer 1 Hewlett-Packa
  iProduct 2 OfficeJet G55
  iSerial 3 SGF0AEGF7CVL
  bNumConfigurations 1
  Configuration Descriptor:
    bLength 9
    bDescriptorType 2
    wTotalLength 39
    bNumInterfaces 1
    bConfigurationValue 1
    iConfiguration 0
    bmAttributes 0x00
      (Missing must-be-set bit!)
      (Bus Powered)
    MaxPower 2mA
    Interface Descriptor:
      bLength 9
      bDescriptorType 4
      bInterfaceNumber 0
      bAlternateSetting 0
      bNumEndpoints 3
      bInterfaceClass 7 Printer
      bInterfaceSubClass 1 Printer
      bInterfaceProtocol 3 IEEE 1284.4 compatible bidirectional
      iInterface 0
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x01 EP 1 OUT
        bmAttributes 2
          Transfer Type Bulk
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0040 1x 64 bytes
        bInterval 0
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x81 EP 1 IN
        bmAttributes 2
          Transfer Type Bulk
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0040 1x 64 bytes
        bInterval 0
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x82 EP 2 IN
        bmAttributes 3
          Transfer Type Interrupt
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0008 1x 8 bytes
        bInterval 255
Device Status: 0x0001
  Self Powered

Sincerely

ender (etch) wrote :
Sanjay Kumar (sanjay-kumar14) wrote :

Hello ender,

Can you try below steps.

=> Run "hp-doctor" command in the terminal

=> Reconfigure print queue using below commands.
       => system-config-printer (remove all print queues)
      => su -c "hp-plugin"
             or
      => sudo hp-plugin (This will download right plugin)
       => hp-setup (It should not be run in a root mode. This command is adding print queue, make sure you select ppd name having "-ps" or "hpcups" substring)
=>Try printing now.

If problem does not get solved then please run following command to capture the logs and send the logs.

$su -c "hp-logcapture"

**Please use "Create a bug report" to attach the logs as "Ask a Question" does not provide the file attachment option

ender (etch) wrote :

Hello

Here are the log files

ender (etch) wrote :

I investigated a little further. The Problem was introduced by the big change of the get_libusb_device() function in "io/hpmud/musb.c" from version 3.12.4 to 3.12.6.

By allowing also bInterfaceProtocol 3 instead of only 1 and 2 my officejet g55 is working again.

I added a patch for hplip-3.13.7.

Sanjay Kumar (sanjay-kumar14) wrote :

Thanks a lot Ender. We will fix this issue in future HPLIP releases.

Changed in hplip:
status: New → Confirmed
status: Confirmed → Fix Committed
assignee: nobody → Sanjay Kumar (sanjay-kumar14)
ender (etch) wrote :

It was my pleasure. I appreciate the effort put into this excellent piece of software
and am happy to give something back.

This fix is available in HPLIP-3.13.9

Changed in hplip:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers