Hp laserjet 1020 not printing on Ubuntu12.10 after power cycle the printer

Bug #1197306 reported by dadidzf on 2013-07-03
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned
hplip (Ubuntu)
Medium
Unassigned

Bug Description

Hi,
Host OS : Ubunu 12.10
Printer : Hp laserjet 1020
Hplip version : 3.13.6
plugin version : 3.13.6

I install the hplip software a few days ago , and it worked well.
Today, i printer some documents as usual, and the papers is not enough, so i just put some more papers in the printer and
power cycle the printer, then the problems come.
The printer never printing again, not print test page too.
And restart the Ubuntu/PC did not help.
When i try to print some page, the Hp manager shows "Task started " "Task completed"....and from the cupsys html page,
i can see the printer is idle, and in good statues, it report no error, and everything seems ok,
but the printer never have a real action. i don't know what happened, what i have done is just powering cycle the printer.

Anyone can help me with this issue ?

By the way, the printer work again after remove the hplip and plugin and re-install it. but i think it is dangerous, sometime, someone power cycle the printer, then it will not work again.

Thanks & Regards.

Hi,
Please follow below steps with attached file.

1) copy attached config_usb_printer.py to /usr/share/hplip folder in root mode.
$ sudo cp config_usb_printer.py /usr/share/hplip/config_usb_printer.py

--> Now restart the printer
--> Perform print job.

Thanks & Regards,
Amarnath

dadidzf (dengzhuangfeng) wrote :

Hi, Amarnath

Thank you very much !
This issure have confused me for two days.
After copying the config_usb_priner.py to /user/share/hplip, this problems never come again.
Can you tell me more details about this file, if this file is absolutely neccessary for the printers on Ubuntu(or linux), then why it is not installed during the installation.

Regards.

Hi Dadidzf,

HP laserjet 1020 printer needs firmware to be downloaded to the device on every reboot. In latest HPLIP build firmware is not being downloaded.
Attached file is patch for the same.

This change will be available in next HPLIP release.

Thanks & Regards,
Amarnath

Changed in hplip:
status: New → In Progress
krishna kumar (kumaranbus) wrote :

This is affecting ubuntu 13.04 users as well.

Changed in hplip:
status: In Progress → Fix Committed
Changed in hplip:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

affects: ubuntu → hplip (Ubuntu)
Changed in hplip (Ubuntu):
status: New → Confirmed
Changed in hplip (Ubuntu):
status: New → Confirmed
Changed in hplip (Ubuntu):
status: Confirmed → Fix Released
Dave Gilbert (ubuntu-treblig) wrote :

fehwalker said on irc that he accidentally set it as fix-released, so undoing.
Triaged seems reasonable since the upstream fix is known.

Hmm low/medium - Medium because it's going to make the printer not work and a lot of people aren't going to be able to figure out the sequence of power off/on in the right order

Changed in hplip (Ubuntu):
importance: Undecided → Medium
status: Fix Released → Triaged
Till Kamppeter (till-kamppeter) wrote :

Ubuntu Saucy ships a newer HPLIP version which contains the patch.

Changed in hplip (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers