Wrong paper tray selection with a HP 8150N

Bug #1197105 reported by Jan-Benedict Glaw
This bug affects 1 person
Affects Status Importance Assigned to Milestone

Bug Description


I got a HP Laserjet 8150N, along with a 2000 sheet stand and would like to use it through a CUPS server running on Debian unstable. Networking and basic communication (eg. with the JetDirect's web interface) work, but I have a hard time getting the printer (properly) to work.

My focus is on getting all paper trays (manual feed, the two internal cassettes and the 2000 sheet stand) to work, as well as both outputs (top and the face-up output to the left.)

First try was to (IIRC) install `printer-driver-hpijs', but I wasn't offered a way to choose the output.

Then I installed `printer-driver-postscript-hp', which gave me (through HP_LaserJet_8150_Series.ppd) access to all input and output trays. However, if I select any specific source tray, the printer always asks me to insert paper into tray #1 (the manual feed tray).

Maybe the commands generated from the PPD are actually wrong for this printer? I already tried to have a look at CUPS' output by intercepting it, but I'm not really used to read PS files, so I couldn't get a lot of infos from it on a first view.

Would be nice if you'd give me some hints how to debug this situation. It seems there's still a lot of documentation for this specific printer available, so I guess it should be possible to make it print from specified source trays into one of the two output bins.

Thanks a lot,

Revision history for this message
Jan-Benedict Glaw (jbglaw) wrote :

I found another issie: Setting a PIN for the print job doesn't make a difference. The printer starts ad hoc, without that I need to enter the PIN when I'm at the printer.

However, the paper tray selection problem is solved. The printer had "punched" paper configured for the 2000 sheet feeder and I selected "plain" paper for printing. Seems the printer re-routes the print job to a tray that has the appropriate paper. After setting all trays to normal paper, source selection works as expected.

So for now, only printing with a PIN doesn't work.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.