HPLIP 3.13.6 stop working after shuting down/rebooting the computer

Bug #1196335 reported by Sergio Rojas on 2013-06-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned

Bug Description

Following up my question on hplip-3.13.6 not working properly under ubuntu 12.04 [ https://answers.launchpad.net/hplip/+question/231450 ], as instructed by Amarnath Chitumalla (amarnath-chitumalla) from a terminal I executed both "hp-doctor"(which did not solved the problem) and " sudo hp-logcapture ".

The output of the latest command is at [ http://www.mediafire.com/?gf5d342c2bjt6z9 ].

I hope this could help Amarnath Chitumalla find out what might be wrong.

Regards,

Sergio

Sergio Rojas (rr-sergio) wrote :

Following up my question on hplip-3.13.6 not working properly under ubuntu 12.04 [ https://answers.launchpad.net/hplip/+question/231450 ], as instructed by Amarnath Chitumalla (amarnath-chitumalla) from a terminal I executed both "hp-doctor"(which did not solved the problem) and " sudo hp-logcapture ".

The output of the latest command is at [ http://www.mediafire.com/?gf5d342c2bjt6z9 ].

I hope this could help Amarnath Chitumalla find out what might be wrong.

Regards,

Sergio

Hi Sergio Rojas,

In above logs, you haven't performed Print Job during hp-logcapture command

$ sudo hp-logcapture
--> perform the Print Job when it prompted.

attach logs again here.

Thanks & Regards,
Amarnath

Hello Amarnath, Here is the new log. As before I did "hp-doctor" followed
by "sudo hp-logcapture" and I tried to print different documents via lpr, gedit,

and acroreadafter prompted  for

Please perform the tasks (Print, scan, fax) for which you need to collect the logs.
Are you done with taks?. Press (y=yes*, q=quit):
Hopefully this time the logs captured enough info to solve this problem.

Sergio

________________________________
 From: Amarnath Chitumalla <email address hidden>
To: <email address hidden>
Sent: Monday, July 1, 2013 2:50 AM
Subject: [Bug 1196335] Re: HPLIP 3.13.6 stop working after shuting down/rebooting the computer

Hi Sergio Rojas,

In above logs, you haven't performed Print Job during hp-logcapture
command

$ sudo hp-logcapture
--> perform the Print Job when it prompted.

attach logs again here.

Thanks & Regards,
Amarnath

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1196335

Title:
  HPLIP 3.13.6 stop working after shuting down/rebooting the computer

Status in HP Linux Imaging and Printing:
  New

Bug description:

  Following up my question on  hplip-3.13.6  not working properly under ubuntu 12.04 [ https://answers.launchpad.net/hplip/+question/231450 ], as instructed by Amarnath Chitumalla (amarnath-chitumalla) from a terminal I  executed both "hp-doctor"(which did not solved the problem) and " sudo hp-logcapture ".

  The output of the latest command is at [
  http://www.mediafire.com/?gf5d342c2bjt6z9 ].

  I hope this could help Amarnath Chitumalla  find out what might be
  wrong.

  Regards,

  Sergio

To manage notifications about this bug go to:
https://bugs.launchpad.net/hplip/+bug/1196335/+subscriptions

Hi Markraptus,

Can't see any error in the attached logs, can you please let us know the following information.
--> run "hp-toolbox" command (HP Device Manager) and click the "status" tab. Do you see any error?

Try following steps,
--> go to hplip source directory
$ cd ~/Downloads/hplip-3.13.6 (change this directory according to your system e.g. ~/Desktop or something else)

$ ./configure --prefix=/usr --enable-libusb01_build

$ make clean
$ make
$ sudo make install

--> Reboot system

$ hp-toolbox
--> remove the printer and setup printer using "-" and "+" icons.

--> perform Print Job.

Thanks & Regards,
Amarnath

Hi Sergio Rojas,

Ignore above comment #5

I made some changes, can you test with following attached file.

1) copy attached config_usb_printer.py to /usr/share/hplip folder in root mode.
$ sudo cp config_usb_printer.py /usr/share/hplip/config_usb_printer.py

--> Now restart the printer
--> Perform print job.

Thanks & Regards,
Amarnath

Changed in hplip:
status: New → Confirmed
status: Confirmed → In Progress
Girish-105 (girish-105) wrote :

ok it works on restart now. (i will check after turning printer off and system and update again.)

thanks

Girish-105 (girish-105) wrote :

ok works even after turning off printer and system. all good now. thanks. :)

Sergio Rojas (rr-sergio) wrote :

Hi Amarnath,

  Your provided new script [
https://bugs.launchpad.net/hplip/+bug/1196335/+attachment/3722841/+files/config_usb_printer.py ]  on " Comment 6 for bug 1196335 "

[ https://bugs.launchpad.net/hplip/+bug/1196335/comments/6 ] fixed the printing

problemfor me too. Now. after starting ubuntu 12.04 on my laptop I can plug the

usb printer to it and print  without the need to reinstall hplip.

Sergio

________________________________
 From: Amarnath Chitumalla <email address hidden>
To: <email address hidden>
Sent: Wednesday, July 3, 2013 5:42 AM
Subject: [Bug 1196335] Re: HPLIP 3.13.6 stop working after shuting down/rebooting the computer

** Changed in: hplip
      Status: New => Confirmed

** Changed in: hplip
      Status: Confirmed => In Progress

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1196335

Title:
  HPLIP 3.13.6 stop working after shuting down/rebooting the computer

Status in HP Linux Imaging and Printing:
  In Progress

Bug description:

  Following up my question on  hplip-3.13.6  not working properly under ubuntu 12.04 [ https://answers.launchpad.net/hplip/+question/231450 ], as instructed by Amarnath Chitumalla (amarnath-chitumalla) from a terminal I  executed both "hp-doctor"(which did not solved the problem) and " sudo hp-logcapture ".

  The output of the latest command is at [
  http://www.mediafire.com/?gf5d342c2bjt6z9 ].

  I hope this could help Amarnath Chitumalla  find out what might be
  wrong.

  Regards,

  Sergio

To manage notifications about this bug go to:
https://bugs.launchpad.net/hplip/+bug/1196335/+subscriptions

Hi,

This fix is released in latest HPLIP-3.13.7 release. Please install hplip-3.13.7 release from http://hplipopensource.com/hplip-web/install.html

Thanks & Regards,
Amarnath

Changed in hplip:
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers