scanimage: open of device hpaio:/net/... failed: Error during device I/O

Bug #1089427 reported by Paolo Pisati on 2012-12-12
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned

Bug Description

hplip-3.12.11

[flag@luxor ~]$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.10
Release: 12.10
Codename: quantal

[flag@luxor ~]$ scanimage -L
device `hpaio:/net/HP_LaserJet_Professional_M1212nf_MFP?zc=NPIF93563' is a Hewlett-Packard HP_LaserJet_Professional_M1212nf_MFP all-in-one

[flag@luxor ~]$ scanimage --format=tiff > test.tiff
scanimage: open of device hpaio:/net/HP_LaserJet_Professional_M1212nf_MFP?zc=NPIF93563 failed: Error during device I/O
[flag@luxor ~]$

Paolo Pisati (p-pisati) wrote :
Paolo Pisati (p-pisati) wrote :

the printer side is ok, while the scanner is completely dead

Joshua Krasnow (allparadigm) wrote :

Same bug for me with Ubuntu 12.10, kubuntu 12.10, mint 14 (all 64bit) using Office jet 6500-709a , both via USB and lan, using hplip from repositories and latest from HP. Hp-check -r returns no errors.
I have tried the previous symlink fix, without success.

I can post more details later if needed

Hi,

Can you please check whether libsane-hpaio.so* files present in "/usr/lib/sane" or "/usr/lib64/sane".

$ ls -l /usr/lib/sane/libsane-hpaio*

$ ls -l /usr/lib64/sane/libsane-hpaio*

if these files are not present in "/usr/lib/sane" folder, then copy these files into "/usr/lib64/sane/" folder.
$ sudo cp /usr/lib64/sane/libsane-hpaio.* /usr/lib/sane/

if these files are present in "/usr/lib/sane" folder, please provide following data.

$ hp-scan -g

Thanks & Regards,
Amarnath

Joshua Krasnow (allparadigm) wrote :

I am not at my computer, but I did check before. I did not have a /usr/lib64/ but I did find the files and copied them over, but I failed to help

Details can be found here
https://bugs.launchpad.net/hplip/+bug/1092768

Joshua Krasnow (allparadigm) wrote :

Unplugging printer and leaving off overnight seems to have solved the problem

go figure

Marc Carter (drekbour) wrote :

ubuntu 12.10 x64, hplip 3.12.6-3ubuntu4
hp-check attached

$ export SANE_DEBUG_DLL=128
$ hp-scan
[dll] load: searching backend `hpaio' in `/usr/lib/x86_64-linux-gnu/sane:/usr/lib/sane'
[dll] load: trying to load `/usr/lib/x86_64-linux-gnu/sane/libsane-hpaio.so.1'
[dll] load: couldn't open `/usr/lib/x86_64-linux-gnu/sane/libsane-hpaio.so.1' (No such file or directory)
[dll] load: trying to load `/usr/lib/sane/libsane-hpaio.so.1'
[dll] load: dlopen()ing `/usr/lib/sane/libsane-hpaio.so.1'
[dll] init: initializing backend `hpaio'
[dll] init: backend `hpaio' is version 1.0.0
[dll] sane_get_devices: found 1 devices
Using device hpaio:/net/Photosmart_Prem_C310_series?zc=HPB2B091
Opening connection to device...
[dll] sane_open: trying to open `hpaio:/net/Photosmart_Prem_C310_series?zc=HPB2B091'
error: SANE: Error during device I/O (code=9)

Paolo Pisati (p-pisati) wrote :

indeed, it worked now, closing here.

Changed in hplip:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers