HP System Tray and Device Manager fails with ValueError exception

Bug #1064889 reported by Ani Balakrishnan on 2012-10-10
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HPLIP
Undecided
Unassigned
hplip (Ubuntu)
High
Till Kamppeter

Bug Description

hplip-3.12.10 on Ubuntu 12.04 the systray icon appears but will not open settings or device manager gui errort as follows:

Traceback (most recent call last):
  File "/usr/bin/hp-toolbox", line 257, in <module>
    toolbox = DevMgr5(__version__, device_uri, None)
  File "/usr/share/hplip/ui4/devmgr5.py", line 204, in __init__
    if not utils.Is_HPLIP_older_version( installed_version, self.user_settings.latest_available_version):
  File "/usr/share/hplip/base/utils.py", line 1927, in Is_HPLIP_older_version
    if(int(installed_array[cnt]) < int(available_array[cnt])):
ValueError: invalid literal for int() with base 10: "10 Public Release</a><br />')"

hp-check -t

HP Linux Imaging and Printing System (ver. 3.12.10)
Dependency/Version Check Utility ver. 15

Copyright (c) 2001-14 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the
HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
are installed to successfully compile HPLIP.
2. Run-time check mode (-r or --run): Use this mode to determine if a distro
supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball
has the proper dependencies installed to successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode
will check both of the above cases (both compile- and run-time dependencies).

Check types:
a. EXTERNALDEP - External Dependencies
b. GENERALDEP - General Dependencies (required both at compile and run time)
c. COMPILEDEP - Compile time Dependencies
d. [All are run-time checks]
PYEXT SCANCONF QUEUES PERMISSION

Status Types:
    OK
    MISSING - Missing Dependency or Permission or Plug-in
    INCOMPAT - Incompatible dependency-version or Plugin-version

Saving output in log file: /home/raena/hp-check.log

Initializing. Please wait...

---------------
| SYSTEM INFO |
---------------

 Kernel: 3.3.6-030306-generic #201205121335 SMP Sat May 12 17:43:01 UTC 2012 GNU/Linux
 Host: pangolin
 Proc: 3.3.6-030306-generic #201205121335 SMP Sat May 12 17:43:01 UTC 2012 GNU/Linux
 Distribution: ubuntu 12.04

-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.12.10
HPLIP-Home: /usr/share/hplip
HPLIP-Installation: Auto installation is supported for ubuntu distro 12.04 version

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf. Generated from hplip.conf.in by configure.

[hplip]
version=3.12.10

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/HP
ppdbase=/usr/share/ppd
doc=/usr/share/doc/hplip-3.12.10
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp

# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=no
foomatic-drv-install=no
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.12.10
restricted-build=no
ui-toolkit=qt4
qt3=no
qt4=yes
policy-kit=no
hpijs-only-build=no
lite-build=no
udev-acl-rules=yes
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no

Current contents of '/var/lib/hp/hplip.state' file:
[plugin]
installed = 1
eula = 1
version = 3.12.10

Current contents of '~/.hplip/hplip.conf' file:
[upgrade]
notify_upgrade = true
last_upgraded_time = 1349750931
pending_upgrade_time = 0
latest_available_version = 3.12.10 Public Release</a><br />');document.write('</li>');document.write('<li class="rss-item"><a class="rss-item" href="http://sourceforge.net/news/?group_id=149981&id=309222" target="_self">HPLIP 3.12.9 Public Release</a><br />');document.write('</li>');document.write('<li class="rss-item"><a class="rss-item" href="http://sourceforge.net/news/?group_id=149981&id=308288" target="_self">HPLIP 3.12.6 Public Release</a><br />');document.write('</li>');document.write('<li class="rss-item"><a class="rss-item" href="http://sourceforge.net/news/?group_id=149981&id=307195" target="_self">HPLIP 3.12.4 Public Release</a><br />');document.write('</li>');document.write('<li class="rss-item"><a class="rss-item" href="http://sourceforge.net/news/?group_id=149981&id=306048" target="_self">HPLIP 3.12.2 Public Release</a><br />');document.write('</li>');document.write('<li class="rss-item"><a class="rss-item" href="http://sourceforge.net/news/?group_id=149981&id=305159" target="_self">HPLIP 3.11.12 Public Release</a><br />');document.write('</li>');document.write('<li class="rss-item"><a class="rss-item" href="http://sourceforge.net/news/?group_id=149981&id=303762" target="_self">HPLIP 3.11.10 Public Release</a><br />');document.write('</li>');document.write('<li class="rss-item"><a class="rss-item" href="http://sourceforge.net/news/?group_id=149981&id=302308" target="_self">HPLIP 3.11.7 Public Release</a><br />');document.write('</li>');document.write('<li class="rss-item"><a class="rss-item" href="http://sourceforge.net/news/?group_id=149981&id=300330" target="_self">HPLIP 3.11.5 Public Release</a><br />');document.write('</li>');document.write('<li class="rss-item"><a class="rss-item" href="http://sourceforge.net/news/?group_id=149981&id=298857" target="_self">HPLIP 3.11.3a

[scan_plugins]
bb_marvell.so = Present
bb_soapht.so = Present
bb_soap.so = Present

[fax_plugins]
fax_marvell.so = Present

[print_plugins]
lj.so = Present

[installation]
date_time = 09/10/12 14:26:13
version = 3.12.10

 <Package-name> <Package-Desc> <Required/Optional> <Min-Version> <Installed-Version> <Status> <Comment>

--------------------------
| External Dependencies |
--------------------------

 gs Ghostscript REQUIRED 7.05 9.05 OK -
 network Network-wget OPTIONAL - 1.13.4 OK -
 dbus DBus REQUIRED - 1.4.18 OK -
 scanimage Shell-Scanning OPTIONAL 1.0 1.0.22 OK -
 policykit Admin-Policy-framework OPTIONAL - 0.104 OK -
 xsane SANE-GUI OPTIONAL 0.9 0.998 OK -
 cups CUPS REQUIRED 1.1 1.5.3 OK 'CUPS Scheduler is running'

-------------------------
| General Dependencies |
-------------------------

 reportlab Python-PDF-Lib OPTIONAL 2.0 2.5 OK -
 libcrypto OpenSSL-Crypto-Lib REQUIRED - 1.0.1 OK -
 pil Python-Image-Lib OPTIONAL - 1.1.7 OK -
 pyqt4-dbus PyQt4-DBUS REQUIRED 4.0 4.9.1 OK -
 libjpeg JPEG-Lib REQUIRED - - OK -
 libpthread POSIX-Threads-Lib REQUIRED - 2.15 OK -
 python-dbus Python-DBUS REQUIRED 0.80.0 1.0.0 OK -
 python-devel Python-SDK REQUIRED 2.2 2.7.3 OK -
 pyqt4 Python-Qt4 REQUIRED 4.0 4.9.1 OK -
 cups-devel CUPS-SDK REQUIRED - 1.5.3 OK -
 sane-devel SANE-SDK REQUIRED - 1.0.22 OK -
 libusb USB-Lib REQUIRED - 1.0 OK -
 sane Scan-Lib REQUIRED - 1.0.22 OK -
 cups-image CUPS-Image-Lib REQUIRED - 1.5.3 OK -
 libnetsnmp-devel SNMP-Networking-SDK REQUIRED 5.0.9 5.4.3 OK -
 python-xml Python-XML-Lib REQUIRED - 2.0.1 OK -
 python-notify Desktop-notifications OPTIONAL - - OK -

------------------------------
| Compile Time Dependencies |
------------------------------

 gcc gcc-Compiler REQUIRED - 4.6.3 OK -
 libtool Build-tools REQUIRED - 2.4.2 OK -
 make GNU-Build-tools REQUIRED 3.0 3.81 OK -

----------------------
| Python Extentions |
----------------------

 cupsext CUPS-Extension REQUIRED - 3.12.10 OK -
 pcardext PhotoCard-Extension REQUIRED - 3.12.10 OK -
 hpmudext IO-Extension REQUIRED - 3.12.10 OK -

-----------------------
| Scan Configuration |
-----------------------

 hpaio HPLIP-SANE-Backend REQUIRED - 3.12.10 OK 'hpaio found in /etc/sane.d/dll.conf'
 scanext Scan-SANE-Extension REQUIRED - 3.12.10 OK -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

device `hpaio:/net/HP_LaserJet_M2727nf_MFP?zc=NPI40F599' is a Hewlett-Packard HP_LaserJet_M2727nf_MFP all-in-one

--------------------------
| DISCOVERED USB DEVICES |
--------------------------

No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

HP_LaserJet_M2727nf_MFP
-----------------------
Type: Printer
Device URI: hp:/net/HP_LaserJet_M2727nf_MFP?zc=NPI40F599
PPD: /etc/cups/ppd/HP_LaserJet_M2727nf_MFP.ppd
PPD Description: HP LaserJet M2727 MFP Series Postscript (recommended)
Printer status: printer HP_LaserJet_M2727nf_MFP is idle. enabled since Tue 09 Oct 2012 14:02:25 EST

HP Linux Imaging and Printing System (ver. 3.12.10)
System Tray Status Service ver. 2.0

Copyright (c) 2001-14 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/__init__.py:127: RuntimeWarning: PyOS_InputHook is not available for interactive use of PyGTK
  set_interactive(1)
Required plug-in status: Installed
Traceback (most recent call last):
  File "/usr/bin/hp-upgrade", line 230, in <module>
    if not utils.Is_HPLIP_older_version(installed_version, HPLIP_latest_ver):
  File "/usr/share/hplip/base/utils.py", line 1927, in Is_HPLIP_older_version
    if(int(installed_array[cnt]) < int(available_array[cnt])):
ValueError: invalid literal for int() with base 10: "10 Public Release</a><br />');document"
Communication status: Good

--------------
| PERMISSION |
--------------

groups user-groups Required - - OK raena adm lp cdrom sudo dip plugdev lpadmin sambashare

-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
None

Missing Optional Dependencies
-----------------------------
None

Total Errors: 0
Total Warnings: 0

No errors or warnings.

Done.

Johannes Meixner (jsmeix) wrote :

Same on openSUSE 12.2 (HPLIP 3.12.4), see

https://bugzilla.novell.com/show_bug.cgi?id=784173

Hi Johannes Meixner,

We have made another HPLIP -3.12.10a release with this fix.

However for existing HPLIP versions (hplip-3.12.4, hplip-3.12.6,hplip-3.12.9,hplip-3.12.10), attached patch needs to be applied.

Patch procedure:-
1. untar upgrade_ValueError_Fix_patch.tar.gz
       $ tar -zxvf upgrade_ValueError_Fix_patch.tar.gz

2. upgrade.py and utils.py files need to be overwritten into "/usr/share/hplip/" folder in root mode.
       $ su -c "cp -f upgrade_ValueError_Fix_patch/upgrade.py /usr/share/hplip/"
       $ su -c "cp -f upgrade_ValueError_Fix_patch/utils.py /usr/share/hplip/base"

3. restart system or restart hp-systray .

Thanks & Regards,
Amarnath

Changed in hplip:
status: New → Confirmed
status: Confirmed → Fix Committed
status: Fix Committed → Fix Released
Johannes Meixner (jsmeix) wrote :

Hello Amarnath,

many thanks for the fast bugfix release HPLIP 3.12.10a!

Such bugfix releases make it easy for distributors
(at least it makes it very easy for me :-)
to provide upstream bugfixes to their users.

Right now I upgraded to HPLIP 3.12.10a in the
openSUSE build service project "Printing".

For openSUSE users:

Binary RPMs with HPLIP 3.12.10a should be available
in a few hours for download at
http://download.opensuse.org/repositories/Printing/

See the openSUSE Printing project description at
https://build.opensuse.org/project/show?project=Printing

Till Kamppeter (till-kamppeter) wrote :

As HP has done an extra rel;ease for this and recommends to apply the fix to older versions of HPLIP we should apply the fix to HPLIP in Quantal.

Changed in hplip (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Till Kamppeter (till-kamppeter)
milestone: none → ubuntu-12.10
Till Kamppeter (till-kamppeter) wrote :

Committed to quantal-proposed.

Changed in hplip (Ubuntu):
status: Triaged → Fix Committed

The attachment "Patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hplip - 3.12.6-3ubuntu4

---------------
hplip (3.12.6-3ubuntu4) quantal-proposed; urgency=low

  * debian/patches/hplip-release-parport.patch: libsane-hpaio does not close
    /dev/parport* after checking for a scanner (LP: #1065582, Red Hat bug
    #1065582).
 -- Till Kamppeter <email address hidden> Thu, 11 Oct 2012 21:40:00 +0200

Changed in hplip (Ubuntu):
status: Fix Committed → Fix Released
alleykat (tib-2000) wrote :

My icon is broken again after updating. Can you please send me (simple) instructions how to fix it?
This:

Patch procedure:-
1. untar upgrade_ValueError_Fix_patch.tar.gz
       $ tar -zxvf upgrade_ValueError_Fix_patch.tar.gz

is not simple enough for me, sorry!
thanks, Alleykat

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Patches

Remote bug watches

Bug watches keep track of this bug in other bug trackers.