Openstack dashboard (horizon) not launching vm instances

Bug #967987 reported by Nikhil S Menon on 2012-03-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Medium
Gabriel Hurley

Bug Description

Hello,

I ran stack.sh and trying to do single node installation in Ubuntu 11.10. In Horizon ( open stack dashboard) when i try to launch VM nothing happens. at times, in UI error appears like this

Error: The server has either erred or is incapable of performing the requested operation. (HTTP 500)

I enabled logging and got logs. Herewith attaching the part of log. Kindly help me.

Nikhil

Nikhil S Menon (nikhilsmenon) wrote :
affects: devstack → horizon
Nikhil S Menon (nikhilsmenon) wrote :

The server has either erred or is incapable of performing the requested operation (HTTP 500)

Andy Chong (andycjw) wrote :

I tried and can't repeat the same error.
Is it possible that your machine is out of resource? (insufficient hdd space, memory, etc)

Nikhil S Menon (nikhilsmenon) wrote :

Nope. I have sufficient memory. Images & Snapshot ->

 Image Name Type Status Public Container Format Actions
 cirros-0.3.0-x86_64-blank Image Active Yes AMI Launch when I launched nothing happens. Attached complete log in zip format

-Nikhil

Andy Chong (andycjw) wrote :

I checked the log, and see that the n-cpu log is empty, is nova compute running?

Nikhil S Menon (nikhilsmenon) wrote :

yes it is working. See latest log.

Andy Chong (andycjw) wrote :

can you go to your nova directory and run 'git status'?
and paste the output here

I suspect it's stuck on cleaning something, I had the same problem launch instance with RPC timeout last time.
And the reason was nova-network was stuck because it can't get the .pid file as semaphore or something.

I dont see your nova-network log this time, so it is running properly?

Best yet, delete everything in /opt/stack
and run stack.sh from scratch, this will probably fix it, it will takes some time, and you'll need to refetch everything though

Nikhil S Menon (nikhilsmenon) wrote :

on cleanup it did work. thanks

Sumit Sengupta (sumit-sngpt) wrote :

I'm facing the same problem that I'm unable to Launch any instance from Horizon dashboard and when I search for the nova processes running then I see that 'nova-network' is not running at all. Is this is the issue in my case?

The logs from nova says:
Caught error: Timeout while waiting on RPC response.

Please help to solve this.

Andy Chong (andycjw) wrote :

you need nova-network running, or else it won't work if you're using devstack

As Sumit noted, the critical error is regarding the RPC call timeout to Nova Network in the logs:

ERROR nova.api.openstack [req-649cd61c-1b78-4adf-a246-50fd087de17a 6948c20a2c744b30aac7713eec738e27 f568648f0d804e4f8ac958db58c3b2e0] Caught error: Timeout while waiting on RPC response.

I thought we had documented that Nova Network is a required service in the readme and docs, but apparently we missed that one and got all the other nova services on the list.

Changed in horizon:
assignee: nobody → Gabriel Hurley (gabriel-hurley)
importance: Undecided → Medium
milestone: none → essex-rc2
status: New → In Progress

Reviewed: https://review.openstack.org/5982
Committed: http://github.com/openstack/horizon/commit/873d9df35786739a5ea24a56e712aac2afece835
Submitter: Jenkins
Branch: master

commit 873d9df35786739a5ea24a56e712aac2afece835
Author: Gabriel Hurley <email address hidden>
Date: Thu Mar 29 18:11:44 2012 -0700

    Added "network" to the list of required nova services.

    Fixes bug 967987.

    Change-Id: Icd6ac8c332815de86b2333640f454a0e8c91e982

Changed in horizon:
status: In Progress → Fix Committed
Sumit Sengupta (sumit-sngpt) wrote :

hey, Thanks Andy for your suggestion and Gabriel for your quick fixing!

Now I've a working setup and this on RHEL!!

I found that nova-network wasn't running in my setup and because of that the error "Timeout while waiting on RPC response" was coming up and also Horizon had issues. I debugged and found the reason why nova-network wasn't running was due to following command failure in nova startup.

"sudo iptables-save -t filter"

This was because in my RHEL machine the setting was such that sudo was to work only with tty. After I disabled this in sudoers file, basically by commenting out following line, all works well when I restarted nova.

#commented out following line in sudoers file (on RHEL)
"Default requiretty"

Thierry Carrez (ttx) on 2012-04-03
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in horizon:
milestone: essex-rc2 → 2012.1

Hi,

I have create an instance in openstack using ubuntu openstack dashboard GUI. But, it will display some error status in instances screen.

Anybody can u provide some suggestion for this issue.

Note:

Here I have attached the some log files and screenshot for your reference.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers