System panel instance list clears tenant when doing asynchronous polling

Bug #964739 reported by Devin Carlen on 2012-03-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Low
Tihomir Trifonov

Bug Description

When watching the system panel's instances list perform asynchronous updates, the host name is dropped and becomes "-".

Jake Dahn (jakedahn) wrote :

For me the tenant becomes blank, not the host name, assuming this is the same bug and just a typo.

Tres Henry (tres) wrote :

Yeah, I think it's the tenant name that goes blank.

Devin Carlen (devcamcar) wrote :

yep, will fix title

summary: - System panel instance list clears hostname when doing asynchronous
- polling
+ System panel instance list clears tenant when doing asynchronous polling
Changed in horizon:
assignee: nobody → Tihomir Trifonov (ttrifonov)

Fix proposed to branch: master
Review: https://review.openstack.org/5857

Changed in horizon:
status: Confirmed → In Progress
Changed in horizon:
status: In Progress → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/5858

Changed in horizon:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/5858
Committed: http://github.com/openstack/horizon/commit/5cd1e5d216997c9d2b6e9fbcbea75c91984a2fed
Submitter: Jenkins
Branch: master

commit 5cd1e5d216997c9d2b6e9fbcbea75c91984a2fed
Author: Tihomir Trifonov <email address hidden>
Date: Tue Mar 27 10:13:05 2012 +0300

    Fix issue with not loading and showing
    tenant name in syspanel/instance view

    Fixes bug 964739

    Patch2: Replaced API calls with _get(),
    added unit test

    The prefill of tenant_name was missing.
    The same code is present in AdminIndexView.
    Maybe it would be better to make UpdateRow as
    part of the TableView, because they share
    almost the same get_data() code...

    Change-Id: Ib74f7049625292644bba41ac0ab17279274a8ca3

Changed in horizon:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-04-03
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in horizon:
milestone: essex-rc2 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers