row actions affects whole table

Bug #960866 reported by Andy Chong on 2012-03-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Critical
Gabriel Hurley

Bug Description

row actions should only have effect on the row item itself, not whole table

expected: 'delete rule' row action should only delete the rule for that row
observed: 'delete rule' row action will delete other rules in form table if its checkbox is checked

this is the same for all row actions in other tables, e.g. floating ips, keypairs, etc

Devin Carlen (devcamcar) on 2012-03-21
Changed in horizon:
importance: Undecided → Critical
status: New → Confirmed
tags: added: essex-rc-potential
Changed in horizon:
assignee: nobody → Nebula (nebula)
Paul McMillan (paul-mcmillan) wrote :

This will be fixed by switching behavior based on which submit button was used to submit the form. This will probably require adding a unique name for each rendered submit button.

Andy Chong (andycjw) wrote :

each submit button already has unique id ready for this, but it's not used in the handling code on server side

Paul McMillan (paul-mcmillan) wrote :

Yes, but we need to copy the id attribute to a name attribute in our rendering, since the id doesn't get submitted.

Devin Carlen (devcamcar) on 2012-03-22
Changed in horizon:
milestone: none → essex-rc2
tags: removed: essex-rc-potential
Changed in horizon:
status: Confirmed → In Progress
assignee: Nebula (nebula) → Gabriel Hurley (gabriel-hurley)

Reviewed: https://review.openstack.org/5981
Committed: http://github.com/openstack/horizon/commit/0142ec0d2bf3820be8823464d0a2fa3b1680d815
Submitter: Jenkins
Branch: master

commit 0142ec0d2bf3820be8823464d0a2fa3b1680d815
Author: Gabriel Hurley <email address hidden>
Date: Thu Mar 29 18:01:58 2012 -0700

    Add preference towards single id for action handling.

    When the action handler received both a single id and multiple
    object ids (such as when a user checks multiple boxes, then selects
    a single row's action), it would previously favor the mutiple
    ids, which goes against the intention of the user. This patch
    causes it to favor the single id now.

    Fixes bug 960866.

    Change-Id: I53034589ada5792c22c2fc5144af2aee3b551eb0

Changed in horizon:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-04-03
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in horizon:
milestone: essex-rc2 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers