updating image redirects from syspanel to project

Bug #960448 reported by Brian Waldon on 2012-03-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Medium
Andy Chong

Bug Description

If I save an image in syspanel (at /syspanel/images/images/), I get redirected to /nova/images_and_snapshots/

Gabriel Hurley (gabriel-hurley) wrote :

It's 'cuz the action is imported from the project dashboard tables.py... I noticed this too.

Changed in horizon:
importance: Undecided → Medium
status: New → Confirmed
Devin Carlen (devcamcar) on 2012-03-20
tags: added: essex-rc-potential

Fix proposed to branch: master
Review: https://review.openstack.org/5599

Changed in horizon:
assignee: nobody → Andy Chong (andycjw)
status: Confirmed → In Progress
Devin Carlen (devcamcar) on 2012-03-22
Changed in horizon:
milestone: none → essex-rc2
Devin Carlen (devcamcar) on 2012-03-22
tags: removed: essex-rc-potential

Reviewed: https://review.openstack.org/5599
Committed: http://github.com/openstack/horizon/commit/d3abf336ee91d2284d6b5d9cbcd99a2a0f481bb1
Submitter: Jenkins
Branch: master

commit d3abf336ee91d2284d6b5d9cbcd99a2a0f481bb1
Author: Andy Chong <email address hidden>
Date: Wed Mar 21 12:02:33 2012 +0800

    updating image should redirect back to original page

     * fix bug 960448
     * syspanel inherits nova UpdateImage view/form
     * add completion_view to form base object, and get_success_url()
       that reverse the proper url for redirection on success
       handling
     * syspanel AdminEditImage was pointless because it didn't
       override the 'url', now fixed

    Change-Id: Ia8f24c7a895b397f11978a59232ab00da3e8813d

Changed in horizon:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-04-03
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in horizon:
milestone: essex-rc2 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers