firefox instance and volumes page weirdness

Bug #960445 reported by andrewsben on 2012-03-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
High
Gabriel Hurley

Bug Description

On firefox 10.0.2, in ubuntu 11.4, the instances and volumes page looks as though it is nesting several instances of the page within the right frame. Screenshot only show the one nested inside, but there are 4 on my page currently if I scroll down.

andrewsben (andrewsben) wrote :

Forgot to attached screenshot...

Andy Chong (andycjw) wrote :

can you show the steps to reproduce this, i can't seemed to recreate this

It happened when I filled my quota with small instances and then tried
to terminate them all at once. I am trying to recreate so I can check
exactly but both in firefox and chrome the scripts are locking up my
browser.

Devin Carlen (devcamcar) on 2012-03-21
Changed in horizon:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Nebula (nebula)
Paul McMillan (paul-mcmillan) wrote :

This is likely related to the ajax row updates.

Andy Chong (andycjw) wrote :

i still can't reproduce this, maybe it's fixed interim?

Devin Carlen (devcamcar) wrote :

Moving to rc2 to track this. If we can't repro it soon I'll mark it as invalid.

Changed in horizon:
milestone: none → essex-rc2
Gabriel Hurley (gabriel-hurley) wrote :

This was previously due to a variety of potential escape vectors in the AJAX code. There's been a lot of work in this area that's patched those holes. I can't say which specific commit fixed this specific bug, but I can't reproduce this in FF or Chrome at this point, even when launching or terminating numerous instances at once. Marking as fixed until a new repro can shed further light on it.

Changed in horizon:
assignee: Nebula (nebula) → Gabriel Hurley (gabriel-hurley)
status: Confirmed → In Progress
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-04-03
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in horizon:
milestone: essex-rc2 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers