Disassociate floating ip dropdown not red like rest of the button

Bug #959674 reported by Jake Dahn on 2012-03-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Medium
Gabriel Hurley

Bug Description

Expected: All of the disassociate floating ip button, including dropdown arrow, should be red.

Actual: The disassociate floating ip dropdown not red like rest of the button http://stsh.me/1QO

Jake Dahn (jakedahn) on 2012-03-19
description: updated
Gabriel Hurley (gabriel-hurley) wrote :

The larger issue here is to solve styling the dropdown arrow element based on the first button, which is not a trivial problem to solve generically.

Changed in horizon:
importance: Undecided → Medium
status: New → Confirmed
tags: added: essex-rc-potential
Devin Carlen (devcamcar) on 2012-03-20
tags: removed: essex-rc-potential
Andy Chong (andycjw) wrote :

a quickfix would be to just use javascript on init to fix this
which i think is acceptable since the dropdown only works if javascript exist

Fix proposed to branch: master
Review: https://review.openstack.org/5601

Changed in horizon:
assignee: nobody → Andy Chong (andycjw)
status: Confirmed → In Progress
Changed in horizon:
assignee: Andy Chong (andycjw) → Gabriel Hurley (gabriel-hurley)

Reviewed: https://review.openstack.org/5601
Committed: http://github.com/openstack/horizon/commit/459a3a20996082ab71756609569b8445b701e110
Submitter: Jenkins
Branch: master

commit 459a3a20996082ab71756609569b8445b701e110
Author: Andy Chong <email address hidden>
Date: Wed Mar 21 13:07:22 2012 +0800

    Dropdown arrow button inherits the same style as main button.

     * fix bug 959674

    Change-Id: Ib19046538876720cf426d099d72f3c26ab81a57f

Changed in horizon:
status: In Progress → Fix Committed
Devin Carlen (devcamcar) on 2012-03-28
Changed in horizon:
milestone: none → essex-rc2
Thierry Carrez (ttx) on 2012-04-03
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in horizon:
milestone: essex-rc2 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers