Active instance should not have resume action

Bug #955697 reported by Emma Grace Steimann on 2012-03-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Medium
Andy Chong

Bug Description

Return/suspend instance is not always correct - sometimes when you have a running/active instance it will say 'resume instance', and when you click it - it will suspend the instance. sometimes it works fine

tags: added: essex-rc1
description: updated
Devin Carlen (devcamcar) on 2012-03-15
tags: added: essex-rc-potential
Changed in horizon:
status: New → Confirmed
importance: Undecided → High
Changed in horizon:
assignee: nobody → Emma Grace Steimann (emmasteimann)
Gabriel Hurley (gabriel-hurley) wrote :

I can't reproduce this. Can you provide any information on how you got to this state?

Gabriel, currently I've been having trouble reproducing this myself. Going to keep attempting to reproduce. When I had come across this previously there didn't seem to be any specific set of events creating this error. I was using http://essex-kvm.rcb.me at the time.

Gabriel Hurley (gabriel-hurley) wrote :

Emma: keep trying. if you can reproduce it, be sure to note how it happens. I'm going to bump this to the "triaged" status and knock it off the essex-rc-potential list for now since we can't actually reliably reproduce it.

Changed in horizon:
importance: High → Medium
status: Confirmed → Triaged
tags: removed: essex-rc-potential essex-rc1
Andy Chong (andycjw) wrote :

i finally get to reproduce this, but i didn't do any specific steps
i just pause/unpause, suspend/resume for a few times and it happens

if i restart the webserver it gets back to normal

my exact steps were:
pause -> unpause -> suspend -> resume
do it a few times and it'll happen

Fix proposed to branch: master
Review: https://review.openstack.org/5676

Changed in horizon:
assignee: Emma Grace Steimann (emmasteimann) → Andy Chong (andycjw)
status: Triaged → In Progress
Devin Carlen (devcamcar) on 2012-03-22
tags: added: essex-rc-potential
Devin Carlen (devcamcar) on 2012-03-22
Changed in horizon:
milestone: none → essex-rc2
Devin Carlen (devcamcar) on 2012-03-22
tags: removed: essex-rc-potential

Reviewed: https://review.openstack.org/5676
Committed: http://github.com/openstack/horizon/commit/700fa8844bb62663b25df1cb39be4dc833786ce8
Submitter: Jenkins
Branch: master

commit 700fa8844bb62663b25df1cb39be4dc833786ce8
Author: Andy Chong <email address hidden>
Date: Thu Mar 22 21:03:48 2012 +0800

    Fix instance row updates polling and actions name

     * fix bug 962034, add suspended/paused as True column status
     * fix bug 955697, forgot to reset the current_present_action

    Change-Id: I16cabd94d176f648bdc695922cd168531a8c4a2a

Changed in horizon:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-04-03
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in horizon:
milestone: essex-rc2 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers