Wrong WSGI path in Ubuntu 12.04 B1

Bug #955054 reported by Kevin Jackson on 2012-03-14
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Critical
Gabriel Hurley
horizon (Ubuntu)
Undecided
Unassigned

Bug Description

Installation of openstack-dashboard on Ubuntu 12.04 B1 isn't usable.

On logging in, no CSS or JS is loaded. On viewing the logs, getting 404s for /static/...*.js and .css.

Viewing /etc/apache2/conf.d/dashboard.conf saw a path issue:

<Directory /usr/share/openstack-dashboard/dashboard/wsgi>
  Order allow,deny
  Allow from all
</Directory>

When /usr/share/openstack-dashboard/dashboard/wsgi doesn't exist or match the WSGIscriptAlias line:
WSGIScriptAlias / /usr/share/openstack-dashboard/openstack_dashboard/wsgi/django.wsgi

On modifying this to match the correct path (given its just permissions) it doesn't change the fact that 404s are still being reported - but that needs to be fixed too.

Package version
ii openstack-dashboard 2012.1~rc1~20120308.1479-0ubuntu1 django web interface to Openstack

Thierry Carrez (ttx) wrote :

The 404s are due to bug 954910
Keeping this open to cover the wsgi path

Devin Carlen (devcamcar) on 2012-03-18
Changed in horizon:
status: New → Confirmed
Gabriel Hurley (gabriel-hurley) wrote :

That WSGI path is definitely all wrong, but I'm not clear on where that file is stored/coming from... Let's make sure this gets sorted out for RC1.

Changed in horizon:
importance: Undecided → High
milestone: none → essex-rc1
Devin Carlen (devcamcar) on 2012-03-18
Changed in horizon:
importance: High → Critical
assignee: nobody → Nebula (nebula)
summary: - Dashboard generally is unusable in Ubuntu 12.04 B1: 404s accessing css,
- js, html
+ Wrong WSGI path in Ubuntu 12.04 B1
Gabriel Hurley (gabriel-hurley) wrote :

Attached patch should fix it in the ubuntu package.

Gabriel Hurley (gabriel-hurley) wrote :

Marking as fixed for horizon since the code in question lives outside this project, and the fix for the Ubuntu package is attached as a patch.

Changed in horizon:
assignee: Nebula (nebula) → Gabriel Hurley (gabriel-hurley)
status: Confirmed → Fix Committed

The attachment "Corrects the wsgi directory path" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Thierry Carrez (ttx) on 2012-03-20
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in horizon:
milestone: essex-rc1 → 2012.1
Chuck Short (zulcss) on 2012-04-12
affects: openstack-dashboard (Ubuntu) → horizon (Ubuntu)
Chuck Short (zulcss) on 2012-04-12
Changed in horizon (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers