search fails if a user has no 'name'

Bug #953809 reported by Guillaume Pernot on 2012-03-13
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
High
Emma Grace Steimann

Bug Description

an exception is risen if a user happens to have 'None' name or e-mail.

attached patch fixes this.

Guillaume Pernot (gpernot) wrote :
Andy Chong (andycjw) wrote :

how do you create a user with no name or email?
via nova command line?

Julien Danjou (jdanjou) wrote :

Users have been created using pre-Essex 4 keystone-manage and then imported using "keystone-manage import_legacy".

Guillaume Pernot (gpernot) wrote :

sorry : there are no null 'name' in my database, the exception is triggered in the second part of the test because of a null 'email'.

the cleaned patch is attached.

Mike Perez (thingee) on 2012-03-13
Changed in horizon:
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/5383

Changed in horizon:
assignee: nobody → Emma Grace Steimann (emmasteimann)
status: Confirmed → In Progress
Devin Carlen (devcamcar) on 2012-03-15
tags: added: essex-rc-potential
Changed in horizon:
importance: Undecided → High
Devin Carlen (devcamcar) on 2012-03-22
Changed in horizon:
milestone: none → essex-rc2
Devin Carlen (devcamcar) on 2012-03-22
tags: removed: essex-rc-potential

Reviewed: https://review.openstack.org/5383
Committed: http://github.com/openstack/horizon/commit/a8ab28ad13ab4803373b36bcb2203357b17a06f6
Submitter: Jenkins
Branch: master

commit a8ab28ad13ab4803373b36bcb2203357b17a06f6
Author: Emma Steimann <email address hidden>
Date: Thu Mar 15 00:03:14 2012 -0500

    Added check to verify email exists when filtering users.

      * fixes bug 953809

    Change-Id: Ib43c404bfc12ec4f6a0c8e47792fad01d1aaeec6

Changed in horizon:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-04-03
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in horizon:
milestone: essex-rc2 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers