ValueError at /syspanel/flavors/create/

Bug #950550 reported by Joe Gordon on 2012-03-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Medium
Tihomir Trifonov

Bug Description

When trying to create a flavor with a non int root Disk GB size, A ValueError is thrown.

(Generated Using Devstack)

ValueError at /syspanel/flavors/create/
invalid literal for int() with base 10: '0.5'
Request Method: POST
Request URL: http://localhost:8080/syspanel/flavors/create/
Django Version: 1.3
Exception Type: ValueError
Exception Value:
invalid literal for int() with base 10: '0.5'
Exception Location: /opt/stack/horizon/openstack_dashboard/wsgi/../../horizon/dashboards/syspanel/flavors/forms.py in handle, line 48
Python Executable: /usr/bin/python
Python Version: 2.7.2
Python Path:
['/opt/stack/horizon/openstack_dashboard/wsgi/../..',
 '/opt/stack/python-keystoneclient',
 '/usr/local/lib/python2.7/dist-packages/prettytable-0.5-py2.7.egg',
 '/usr/local/lib/python2.7/dist-packages/httplib2-0.7.4-py2.7.egg',
 '/opt/stack/python-novaclient',
 '/opt/stack/keystone',
 '/usr/local/lib/python2.7/dist-packages/pam-0.1.4-py2.7.egg',
 '/usr/local/lib/python2.7/dist-packages',
 '/usr/lib/pymodules/python2.7',
 '/opt/stack/glance',
 '/opt/stack/nova',
 '/opt/stack/python-quantumclient',
 '/usr/lib/python2.7',
 '/usr/lib/python2.7/plat-linux2',
 '/usr/lib/python2.7/lib-tk',
 '/usr/lib/python2.7/lib-old',
 '/usr/lib/python2.7/lib-dynload',
 '/usr/lib/python2.7/dist-packages',
 '/usr/lib/python2.7/dist-packages/PIL',
 '/usr/lib/python2.7/dist-packages/gtk-2.0',
 '/opt/stack/horizon/openstack_dashboard']

Changed in horizon:
assignee: nobody → Tihomir Trifonov (ttrifonov)
Devin Carlen (devcamcar) on 2012-03-12
Changed in horizon:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → essex-rc1
Tres Henry (tres) on 2012-03-12
Changed in horizon:
assignee: Tihomir Trifonov (ttrifonov) → Tres Henry (tres)
status: Confirmed → In Progress
Tres Henry (tres) wrote :

Tihomir: when you are working on a bug make sure to mark the bug as "in progress". Also always submit your reviews with "bug 950550" so that gerrit can associate your code with the bug.

Changed in horizon:
assignee: Tres Henry (tres) → Tihomir Trifonov (ttrifonov)
Tres Henry (tres) wrote :

Actually it looks like you did include the bug number in your review but for some reason garret didn't update the bug. So ignore the above comment.

Reviewed: https://review.openstack.org/5217
Committed: http://github.com/openstack/horizon/commit/c9f566dde77a2b7fc922b1b3cceb7f3cde83fbcc
Submitter: Jenkins
Branch: master

commit c9f566dde77a2b7fc922b1b3cceb7f3cde83fbcc
Author: Tihomir Trifonov <email address hidden>
Date: Sun Mar 11 17:11:53 2012 +0200

    Changed CharField to IntegerField in forms
    where the actual value is expected to be integer.

    Fixes bug 950550

    Change-Id: I8a78284ae8513c3a607b2ecad1ea36db2c247c56

Changed in horizon:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-03-20
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in horizon:
milestone: essex-rc1 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers