I can launch a server without a keypair

Bug #949584 reported by Adrian Moya on 2012-03-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Low
Gabriel Hurley

Bug Description

I'm not sure if this is the intented functionality, but when I login for the first time in horizon, when I have not created a keypair, I am able to launch instances without a keypair selected.

After that, when I create a keypair, I am not able no launch an instance without keypair.

Should the keypair be a required field? (And thus I should not be able to launch instances without a kerpair?) or
When there are keypairs created, should I be also able to launch an instance without keypair? (And thus the form should let me select none).

Andy Chong (andycjw) wrote :

from my understanding, it's not required to use a keypair to launch instance

but i'm not sure if it's really a good way to allow instance launch without keypair in the UI
since it's pointless unless the image is self-made and you know the password to it
or has already embedded some key inside, which some people uses to do so programatically
via API instance launch for load balance purpose and such.

maybe the launch form should add a create keypair link if no keypair is available?

Devin Carlen (devcamcar) wrote :

I've always leaned towards allowing an instance to be launched without a keypair, though some new users find it a bit confusing. I agree that either way we should enforce this or not and at least be consistent about it.

My recommendation is to allow running an instance with no keypair.

Changed in horizon:
status: New → Confirmed
importance: Undecided → Low
milestone: none → essex-rc1
assignee: nobody → Nebula (nebula)
Tres Henry (tres) wrote :

It is a completely valid use case to launch an instance without a keypair (cirros image for example). Probably the easiest fix for this is to add a default "Select Keypair" value to the drop-down so that even if the user has defined keypairs they can still launch without.

Not a blocker though so untargeting from rc1.

Changed in horizon:
milestone: essex-rc1 → none
Tres Henry (tres) on 2012-03-13
Changed in horizon:
assignee: Nebula (nebula) → Gabriel Hurley (gabriel-hurley)
status: Confirmed → Fix Committed
Changed in horizon:
milestone: none → essex-rc1
Thierry Carrez (ttx) on 2012-03-20
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in horizon:
milestone: essex-rc1 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers