Unable to delete volumes

Bug #944455 reported by Brian Waldon on 2012-03-02
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Medium
Tres Henry

Bug Description

In a fresh devstack install, I can't delete volumes: http://stsh.me/1JX

Jake Dahn (jakedahn) on 2012-03-02
Changed in horizon:
status: New → Confirmed
Andy Chong (andycjw) wrote :

I have the same problem and the volume creation seems to have problem, it always return error for me, which log should I refer to see what caused this? I checked nova-api and found nothing interesting

Gabriel Hurley (gabriel-hurley) wrote :

Please test this and close or confirm. Thanks!

Changed in horizon:
assignee: nobody → Tres Henry (tres)
assignee: Tres Henry (tres) → nobody
milestone: none → essex-rc1
assignee: nobody → Tres Henry (tres)
importance: Undecided → Medium
status: Confirmed → New
Tres Henry (tres) on 2012-03-06
Changed in horizon:
status: New → Confirmed
Tres Henry (tres) on 2012-03-09
Changed in horizon:
assignee: Tres Henry (tres) → John Postlethwait (john-postlethwait)
status: Confirmed → In Progress
Tres Henry (tres) wrote :

Ugh, looks like volume delete and detach are both broken. Looks like something changed recently with cinderclient.

Changed in horizon:
assignee: John Postlethwait (john-postlethwait) → Tres Henry (tres)

Reviewed: https://review.openstack.org/5183
Committed: http://github.com/openstack/horizon/commit/d5c438a3c803f0e6602614c29f631cfeaa95cfeb
Submitter: Jenkins
Branch: master

commit d5c438a3c803f0e6602614c29f631cfeaa95cfeb
Author: Tres Henry <email address hidden>
Date: Fri Mar 9 16:29:34 2012 -0800

    Removed id sanitizers now that cinder client does the right thing.

    Fixes bug: 944455

    Change-Id: I98c463dd91936b920b53e09b14f575bdacff1cf6

Changed in horizon:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-03-20
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in horizon:
milestone: essex-rc1 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers