overview filter should default to current month

Bug #931227 reported by Paul McMillan on 2012-02-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Low
Tihomir Trifonov

Bug Description

The usage overview page filter should default to the current month rather than January.

Changed in horizon:
assignee: nobody → Tihomir Trifonov (ttrifonov)

Fix proposed to branch: master
Review: https://review.openstack.org/4131

Changed in horizon:
status: New → In Progress

Reviewed: https://review.openstack.org/4131
Committed: http://github.com/openstack/horizon/commit/7e717f3358619327afd7dda9908390f0d535cf0b
Submitter: Jenkins
Branch: master

commit 7e717f3358619327afd7dda9908390f0d535cf0b
Author: Tihomir Trifonov <email address hidden>
Date: Tue Feb 14 12:29:43 2012 +0200

    Sets default values for month/year at Usage Form in overview page

    Fixes bug 931227. The problem is with using 'initial' values for
    a bound form. These are mutually exclusive.
    Another solution is to use only unbound form,
    with setting:
     forms.DateForm(initial={'month':
      self.request.GET.get('month', self.today.month,..)
    but in that case all further validations for the form
    will be disregarded(although there is no validation atm)

    Change-Id: Ie4565b03a1414a0008abfd793d9ec4a181e0aa24

Changed in horizon:
status: In Progress → Fix Committed
Devin Carlen (devcamcar) on 2012-02-15
Changed in horizon:
milestone: none → essex-4
importance: Undecided → Low
Thierry Carrez (ttx) on 2012-02-29
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in horizon:
milestone: essex-4 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers