Region switch dropdown shown but empty with only one region

Bug #929886 reported by Gabriel Hurley on 2012-02-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Low
Gabriel Hurley

Bug Description

There's a missing "len()" call in the context processor which causes the region switcher to appear when it shouldn't.

Changed in horizon:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Gabriel Hurley (gabriel-hurley)
milestone: none → essex-4

Fix proposed to branch: master
Review: https://review.openstack.org/3986

Changed in horizon:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/3986
Committed: http://github.com/openstack/horizon/commit/4d8a924862378e79385513eda0a0321f65cd2a7d
Submitter: Jenkins
Branch: master

commit 4d8a924862378e79385513eda0a0321f65cd2a7d
Author: Gabriel Hurley <email address hidden>
Date: Thu Feb 9 15:16:22 2012 -0800

    Improved region switcher.

    Adds the ability to live-switch regions, and bakes in support at a
    lower level. Cleans up login-related code.

    Makes the login view capable of being used as a modal dialog.

    Overall UX improvements for region support.

    Fixes a bug where having one region would still show the region
    switcher inappropriately. Fixed bug 929886.

    BACKWARDS INCOMPATIBLE CHANGE: If you were an early adopter of
    the region switcher, you will need to reverse the order of the
    settings tuples from the previous ("region name", "endpoint")
    order to the new ("endpoint", "region name") style. This change
    was done to better suit Django's "choices" syntax since the
    original ordering was arbitrary.

    Change-Id: I79db4ec1e608ee0f35916966c018d2a76b5ff662

Changed in horizon:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-02-29
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in horizon:
milestone: essex-4 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers