Attempting to launch or terminate multiple instances results in OS-EXT-STS attribute errors

Bug #929106 reported by Jay Pipes on 2012-02-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
High
Unassigned

Bug Description

Same error messages appear when launching or terminating a bunch of instances... (see screenshot).

Basically, I'm not sure if the OS-EXT-STS extension is installed via devstack or not. What I *do* know is that an attribute error should not be displayed -- if the server task_state attribute doesn't exist, the Task column in the output of the instances listing shouldn't even be displayed.

Jay Pipes (jaypipes) wrote :
Devin Carlen (devcamcar) on 2012-02-20
Changed in horizon:
status: New → Confirmed
importance: Undecided → High
milestone: none → essex-4
Changed in horizon:
assignee: nobody → Emma Grace Steimann (emmasteimann)
Jake Dahn (jakedahn) wrote :

Unable to reproduce, I believe this may have been fixed, or you were just missing the nova api extension which provides the functionality.

Could someone else confirm?

Gabriel Hurley (gabriel-hurley) wrote :

Bumping to 2012.1 since there's no patch. Would like to confirm this is still a valid issue as well.

Changed in horizon:
milestone: essex-4 → 2012.1
Thierry Carrez (ttx) on 2012-02-29
Changed in horizon:
milestone: 2012.1 → essex-rc1

I'm unable to reproduce this same as well. This must have been fixed at some point.

Changed in horizon:
assignee: Emma Grace Steimann (emmasteimann) → nobody
Jake Dahn (jakedahn) wrote :

I think this bug was fixed in an unknown prior commit, I'm going to go ahead and mark it as committed; please reopen if it pops up again.

Changed in horizon:
status: Confirmed → Fix Committed
Thierry Carrez (ttx) on 2012-03-20
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in horizon:
milestone: essex-rc1 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments