Project selector only displays current project

Bug #927939 reported by Gabriel Hurley on 2012-02-06
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
High
Gabriel Hurley

Bug Description

When logged in, the token used to retrieve the tenant list is scoped to the current tenant. Thusly the list of available projects is limited to just the current one. We need to use the unscoped token to reliably retrieve a list of the available authorized tenants.

Changed in horizon:
assignee: nobody → Gabriel Hurley (gabriel-hurley)
importance: Undecided → High
milestone: none → essex-4
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/3826

Changed in horizon:
status: Confirmed → In Progress
summary: - Project selector doesn't have all the authorized projects
+ Project selector only displays current project
description: updated

Reviewed: https://review.openstack.org/3826
Committed: http://github.com/openstack/horizon/commit/6892653c0573a6a55f359cce6c1796053ef65cbf
Submitter: Jenkins
Branch: master

commit 6892653c0573a6a55f359cce6c1796053ef65cbf
Author: Gabriel Hurley <email address hidden>
Date: Mon Feb 6 14:42:56 2012 -0800

    Use unscoped token to fetch authorized projects. Fixes bug 927939.

    Change-Id: I71c53b5dab068ea5ac4f87c86d464cc79c331b26

Changed in horizon:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-02-29
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in horizon:
milestone: essex-4 → 2012.1
He Zhenxing (hezx) wrote :

The problem still exists in the final release of 2012.1.

He Zhenxing (hezx) wrote :

It turns out the problem is actually bug#982595, and can be solved by uncomment the following line in local_settings:

OPENSTACK_ENDPOINT_TYPE = "publicURL"

Hope this can help others that run into the same problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers