Improve instance detail vnc tab

Bug #926338 reported by Jake Dahn on 2012-02-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Undecided
Jake Dahn

Bug Description

Originally reported by anotherjesse.

Expected:

I should see the full terminal, and be able to interact with it.

Actual:

When I go to the vnc tab on the instance detail page, the iframe cuts off part of the console and it doesn't always accept keyboard/mouse input.

Jake Dahn (jakedahn) on 2012-02-03
Changed in horizon:
status: New → Incomplete
status: Incomplete → Confirmed
assignee: nobody → Jake Dahn (jakedahn)
Jake Dahn (jakedahn) wrote :

So our noVNC solution works but is kind of choppy.

When I load the page with noVNC in an iframe I must click the status bar within the iframe for it to begin recognizing my keyboard input. Clicking on the main part of the console (the intuitive thing to do) does not work because of a weird issue with running canvas inside of an iframe.

So I added a notice stating that you should click the grey status bar :/

This is fine for now, but I think eventually we should think about embedding the js right into the page somehow.

Fix proposed to branch: master
Review: https://review.openstack.org/3771

Changed in horizon:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/3771
Committed: http://github.com/openstack/horizon/commit/a5d73d9fc472f1fca9dbb7562778e24f1d0a5331
Submitter: Jenkins
Branch: master

commit a5d73d9fc472f1fca9dbb7562778e24f1d0a5331
Author: jakedahn <email address hidden>
Date: Fri Feb 3 13:38:45 2012 -0800

    Slightly imrpoved usability of noVNC console

      * Sort of fixes bug 926338 :/
      * Removed iframe border, it doesn't fit with the rest of the design decisions in horizon.
      * Added a notice above the vnc console about getting console to recognize keyboard input.

    Change-Id: I75da0d01cc00ca207940972fbcdf492f3d642b9c

Changed in horizon:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-02-29
Changed in horizon:
milestone: none → essex-4
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in horizon:
milestone: essex-4 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers