The attribute description doesn't exist on horizon.api.keystone.Tenant

Bug #921704 reported by Dolph Mathews on 2012-01-25
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Medium
Gabriel Hurley

Bug Description

Running devstack master against keystone master, backed by postgres 9.1... everything seems to work fine, including creating tenants through horizon w/ a description... except seemingly-inconsequential error messages are displayed (see screenshot).

Screenshot: http://i.imgur.com/CmX0l.png

Creating new tenants doesn't seem to result in additional errors.

Dolph Mathews (dolph) wrote :

Assigning this to horizon; it appears that if keystone has a NULL value for a tenant description (tenants.desc = NULL in the keystone db), keystone won't return the attribute at all via it's API (it's optional, per identity spec), but horizon is still expecting it to find it, regardless.

If a tenant description is not returned by keystone, no error should be displayed in horizon.

affects: keystone → horizon
Mike Perez (thingee) on 2012-01-27
Changed in horizon:
status: New → Confirmed
Devin Carlen (devcamcar) on 2012-01-27
Changed in horizon:
importance: Undecided → Medium
milestone: none → essex-4
Gabriel Hurley (gabriel-hurley) wrote :
Changed in horizon:
assignee: nobody → Gabriel Hurley (gabriel-hurley)
status: Confirmed → Fix Committed
Thierry Carrez (ttx) on 2012-02-29
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in horizon:
milestone: essex-4 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers