Popup menus appear in strange, unusable location on Fedora16

Bug #918452 reported by Cole Robinson on 2012-01-18
This bug report is a duplicate of:  Bug #920820: Popup dialogs buggy in Firefox. Edit Remove
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Medium
Unassigned

Bug Description

On my F16 machine with Firefox 9.0.1, dashboard's popup menus don't work (the example I'm trying is under 'instances + volumes'->'edit instance' menu).

Hovering over causes the menu to appear quickly in the top left corner, disappearing soon after since the mouse isn't anywhere near the menu to keep it active.

I assume this must be working for someone, so if this isn't the correct fix I'll be glad to help debug the situation further.

Devin Carlen (devcamcar) on 2012-01-18
Changed in horizon:
milestone: none → essex-4
importance: Undecided → Medium
Cole Robinson (crobinso) wrote :

I've submitted a patch that fixes things for me:

https://review.openstack.org/#change,3157

Devin Carlen (devcamcar) on 2012-01-18
Changed in horizon:
milestone: essex-4 → essex-3
assignee: nobody → Cole Robinson (crobinso)
status: New → In Progress
Cole Robinson (crobinso) wrote :

Apparently that patch isn't really correct, and this is a behavior difference between chrome and firefox at least. I've about reached the end of my css skill already so maybe someone else has thoughts.

Googling around a bit I did find these which may be relevant (possibly fixed in firefox 10)

https://bugzilla.mozilla.org/show_bug.cgi?id=10209
https://developer.mozilla.org/en/CSS/position#Gecko_notes

Cole Robinson (crobinso) wrote :

Removed myself as assignee since I don't think I have the skillz at this point to fix it :)

Changed in horizon:
assignee: Cole Robinson (crobinso) → nobody
Devin Carlen (devcamcar) on 2012-01-23
Changed in horizon:
milestone: essex-3 → essex-4
status: In Progress → Confirmed
Devin Carlen (devcamcar) wrote :
Changed in horizon:
milestone: essex-4 → none
status: Confirmed → Invalid
Mike Perez (thingee) wrote :

Absolute doesn't work in Firefox from my experience across all operating systems. Relative would work, but it would cause the table to expand with ul.rows_action being set to active class.

Tables do not respect absolute, you have to have a container wrapped around set to relative for this to work.

Reviewed: https://review.openstack.org/3385
Committed: http://github.com/openstack/horizon/commit/db1842c3d674a3155e0a193e98db8684a882f737
Submitter: Jenkins
Branch: master

commit db1842c3d674a3155e0a193e98db8684a882f737
Author: Gabriel Hurley <email address hidden>
Date: Tue Jan 24 14:33:25 2012 -0800

    Bootstrap 2!

    Implements blueprint bootstrap-2.

    Notable changes:

      * Uses new split-dropdown buttons. Fixes bug 920820 and fixes bug 918452.
      * Uses bootstrap dropdowns for all menus. No differing implementations now.
      * Reworks how css class attributes are consructed on actions to make them
        easier to works with and support default classes.

    Change-Id: Ia25edb6d8ca8a2d1ef30e8f9a36331eff4c7ae86

Changed in horizon:
status: Invalid → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.