sidebar text language did not change after setting the horizon language

Bug #910297 reported by Tiantian Gao on 2011-12-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
High
Gabriel Hurley

Bug Description

After choose a different language in the setting panel , the language of right column of the page will change ,but the langugege of sidebar did not change

Devin Carlen (devcamcar) on 2011-12-31
Changed in horizon:
status: New → Confirmed
importance: Undecided → High
milestone: none → essex-3
Tiantian Gao (gtt116) on 2012-01-01
Changed in horizon:
assignee: nobody → gtt116 (gtt116)
Devin Carlen (devcamcar) on 2012-01-25
Changed in horizon:
milestone: essex-3 → essex-4
Gabriel Hurley (gabriel-hurley) wrote :

Bumping to 2012.1 so we can do a thorough translation/string freeze review.

Changed in horizon:
milestone: essex-4 → 2012.1
Thierry Carrez (ttx) on 2012-02-29
Changed in horizon:
milestone: 2012.1 → essex-rc1
Changed in horizon:
assignee: gtt116 (gtt116) → Gabriel Hurley (gabriel-hurley)
Andy Chong (andycjw) wrote :

this bug is very peculiar, sometimes it doesn't just affect the sidebar
http://i.imgur.com/eyM2E.png
only a few strings get changed, while the rest is still the same

Andy Chong (andycjw) wrote :

I have tried setting ugettext to ugettext_lazy and it doesn't help at all
anyone has any idea why this bug happens?

Tres Henry (tres) wrote :

Untargeting for rc since this is not a blocking issue.

Changed in horizon:
milestone: essex-rc1 → none
Andy Chong (andycjw) wrote :

what is the progress for this bug? will it be fixed in essex?
is there any hint on how to attack this problem?

Devin Carlen (devcamcar) on 2012-03-22
tags: added: essex-rc-potential
Devin Carlen (devcamcar) wrote :

We'll be re-examining this for rc2.

Changed in horizon:
milestone: none → essex-rc2
tags: removed: essex-rc-potential
Changed in horizon:
status: Confirmed → Triaged
status: Triaged → In Progress
Gabriel Hurley (gabriel-hurley) wrote :

The proposed fix (to the best of my testing) fully fixes this problem. However, it's a little non-obvious, because there are still some missing/untranslated strings...

Reviewed: https://review.openstack.org/5717
Committed: http://github.com/openstack/horizon/commit/ab71aff23f30360e8463d3a5ca2cec5719994b8c
Submitter: Jenkins
Branch: master

commit ab71aff23f30360e8463d3a5ca2cec5719994b8c
Author: Gabriel Hurley <email address hidden>
Date: Thu Mar 22 15:12:37 2012 -0700

    Rework translation for panel and dashboard names. Marked more strings.

    Uses ugettext_lazy to delay translation; reworks the __repr__
    method to avoid using the translated form; and changes the
    unicode method of the HorizonComponent class to actually return a
    string coerced to unicode rather than a proxy object.

    In the process, many more strings which had been missed have been
    marked for translation.

    Fixes bug 910297.

    Change-Id: Ie8d10a928b0419313e6c54b0eff7a3a37299ca83

Changed in horizon:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-04-03
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in horizon:
milestone: essex-rc2 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers