Consistent terminology for Project/Dashboard/Tenant

Bug #909495 reported by Gabriel Hurley on 2011-12-28
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Medium
Gabriel Hurley

Bug Description

As per Horizon skype channel discussion, we need to standardize the Dashboard/Project/Tenant naming conventions. Agreement seems to be centered around Project being the preferred user-facing term. To avoid confusion around project/tenant, all user-facing instances of tenant will be replaced with project, and help text + documentation should be written to make it clear to people who care what the relationship between project and tenant is.

Changed in horizon:
assignee: nobody → Gabriel Hurley (gabriel-hurley)
status: New → Confirmed
Devin Carlen (devcamcar) on 2011-12-28
Changed in horizon:
importance: Undecided → Medium
milestone: none → essex-3
Jay Pipes (jaypipes) wrote :

I would love it if we could use Account instead of either Project or Tenant... Tenant is cryptic for anyone other than a service provider. Project doesn't really describe what it is, IMHO. Account is the correct term: a grouping for users.

Anyway, just my 2 cents, nothing more :)

Devin Carlen (devcamcar) on 2012-01-25
Changed in horizon:
milestone: essex-3 → essex-4

Fix proposed to branch: master
Review: https://review.openstack.org/3838

Changed in horizon:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/3838
Committed: http://github.com/openstack/horizon/commit/87e6970a540587cbf9814aa554a4d04fec9c4106
Submitter: Jenkins
Branch: master

commit 87e6970a540587cbf9814aa554a4d04fec9c4106
Author: Gabriel Hurley <email address hidden>
Date: Mon Feb 6 18:05:33 2012 -0800

    Renamed all user-facing cases of "tenant" to "project".

    This required a little more refactoring than expected because I
    wanted to make the url slug also say "project", which required
    changing the panel slug, which in turn required changing the name of
    the panel directory, and then it seemed silly not to make the template
    directory match.

    Fixed bug 909495.

    Change-Id: I9da3b544b46f507a223a44c256d0008c8674ab3b

Changed in horizon:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-02-29
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in horizon:
milestone: essex-4 → 2012.1
Matt Joyce (matt-nycresistor) wrote :

This is a terrible decision and generates confusion among users. Please change to tenant as what you are displaying is in fact tenant data and not project data.

Devin Carlen (devcamcar) wrote :

@Matt Joyce: Keystone is the only project that uses tenant now. And it will be renaming tenant to project as well during the Folsom timeframe to put this issue to bed once and for all.

Matt Joyce (matt-nycresistor) wrote :

Glance still uses the term tenant.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers