Unavailable Glance endpoint causes crash

Bug #906483 reported by Devin Carlen on 2011-12-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Medium
Emma Grace Steimann

Bug Description

Try/except logic should be wrapped around glance client calls and an error message "The image store is currently unavailable." instead of a full blown django stack trace.

Joseph Heck (heckj) on 2012-01-11
Changed in horizon:
assignee: Gabriel Hurley (gabriel-hurley) → Emma Grace Steimann (emmasteimann)
Jake Dahn (jakedahn) wrote :

Unable to reproduce, this has been fixed during gabriel's refactors.

Changed in horizon:
status: Confirmed → Fix Committed
Thierry Carrez (ttx) on 2012-01-25
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in horizon:
milestone: essex-3 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers