Unable to delete snapshots

Bug #902361 reported by Jake Dahn on 2011-12-09
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
High
Gabriel Hurley

Bug Description

Steps to repro:
  1. Create a snapshot of an instance.
  2. Go to images page.
  3. Click the 'delete' action for the snapshot you just created.

Behavior expected:
  1. Snapshot is deleted, and I'm greeted with a success or info flash message.

Behavior actual:
  1. Snapshot not deleted.
  2. error: 'you are not the owner of this image'
  3. Screenshot: http://stsh.me/yN

Gabriel Hurley (gabriel-hurley) wrote :

There's definitely wonkiness there.

Changed in horizon:
status: New → Confirmed
Jay Pipes (jaypipes) wrote :

Yep, I see this all the time. Mostly annoying, because the workaround is simply to click on the syspanel and delete from that panel's images list...

Devin Carlen (devcamcar) on 2011-12-17
Changed in horizon:
importance: Undecided → High
assignee: nobody → Tres Henry (tres)
milestone: none → essex-3
Gabriel Hurley (gabriel-hurley) wrote :

It was previously comparing ids to names. this has been corrected.

Changed in horizon:
assignee: Tres Henry (tres) → Gabriel Hurley (gabriel-hurley)
status: Confirmed → Fix Committed
Thierry Carrez (ttx) on 2012-01-25
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in horizon:
milestone: essex-3 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers