differences in overview vs instances

Bug #897094 reported by Jesse Andrews on 2011-11-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
High
Jake Dahn

Bug Description

ID and Status appears different in overview and instances page.

Steps:

1) install essex devstack
2) login to dashboard
3) launch a single VM
4) visit overview and instances

Expected:

same status/State and ID and size/flavor

Actual:

ID is 1 in overview, UUID in instances list
status is none in overview, Active in instances
flavor is name in overview and "0bytes Ram VCPU GB Disk" in list

Jesse Andrews (anotherjesse) wrote :
Devin Carlen (devcamcar) on 2011-11-28
Changed in horizon:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Jake Dahn (jakedahn)
milestone: none → essex-2
Devin Carlen (devcamcar) on 2011-12-12
Changed in horizon:
milestone: essex-2 → essex-3

Fix proposed to branch: master
Review: https://review.openstack.org/2752

Changed in horizon:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/2752
Committed: http://github.com/openstack/horizon/commit/01b507001df2f457c938c5fc2a7099e623beae3a
Submitter: Jenkins
Branch: master

commit 01b507001df2f457c938c5fc2a7099e623beae3a
Author: jakedahn <email address hidden>
Date: Tue Jan 3 10:31:25 2012 -0800

    Fix inconsistencies between overview and index.

    However the tables are not identical, because the overview page serves a
    different purpose than the instance list.

    fixes bug 897094

    Change-Id: Ic8de38418e3d206ed6a0f184062ef0ca9f20db65

Changed in horizon:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-01-25
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in horizon:
milestone: essex-3 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers