OpenStack Dashboard (Horizon)

"Error fetching floating ips: The server has either erred or is incapable of performing the requested operation." when none allocated to tenant

Reported by Jesse Andrews on 2011-11-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Undecided
Jesse Andrews
Diablo
Undecided
Unassigned
OpenStack Dashboard (Horizon)
Medium
Jesse Andrews

Bug Description

Before you allocate any ips you see an error

steps:

1) install devstack essex (master)
2) login to dashboard
3) click on the floating ip section

expected:

an empty list/table for my IPs and instructions on how to allocate

actual:

A red bar proclaims: Error: Error fetching floating ips: The server has either erred or is incapable of performing the requested operation.

I think this is actually because nova is returning an error when you do floating IP list since if you allocate an ip (using dashboard or cli) further views to this page work as expected.

Jesse Andrews (anotherjesse) wrote :

To verify breakage via the CLI:

1) install devstack (essex / master)
2) source openrc
3) execute nova floating-ip-list

result:

$ cd devstack
$ . openrc
$ nova floating-ip-list
The server has either erred or is incapable of performing the requested operation. (HTTP 500)

tags: added: low-hanging-fruit
Devin Carlen (devcamcar) on 2011-11-28
Changed in horizon:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → essex-2
milestone: essex-2 → essex-3
Jesse Andrews (anotherjesse) wrote :
Changed in horizon:
status: Confirmed → Fix Committed
Changed in nova:
status: New → Fix Committed
milestone: none → essex-2
Devin Carlen (devcamcar) on 2011-12-13
Changed in horizon:
assignee: nobody → anotherjesse (anotherjesse)
milestone: essex-3 → essex-2
Thierry Carrez (ttx) on 2011-12-14
Changed in nova:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2011-12-14
Changed in horizon:
status: Fix Committed → Fix Released
Mark McLoughlin (markmc) on 2012-04-03
Changed in nova:
assignee: nobody → Jesse Andrews (anotherjesse)
Thierry Carrez (ttx) on 2012-04-05
Changed in horizon:
milestone: essex-2 → 2012.1
Thierry Carrez (ttx) on 2012-04-05
Changed in nova:
milestone: essex-2 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers