-N argument to run_test.sh does not work as specified

Bug #894776 reported by Julien Danjou on 2011-11-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Undecided
Gabriel Hurley

Bug Description

$ ./run_tests.sh -N
Checking environment.
Your environment appears to be out of date. Update? (Y/n) n
Error: Test script not found at horizon/bin/test. Did buildout succeed?

Gabriel Hurley (gabriel-hurley) wrote :

Yes, to run the test suite your are required to have an environment created using the buildout script. This is to ensure consistency across test runs, installations, etc. and make sure all the arguments to the test runners are set correctly.

Changed in horizon:
assignee: nobody → Gabriel Hurley (gabriel-hurley)
status: New → Invalid
Devin Carlen (devcamcar) on 2011-12-09
Changed in horizon:
milestone: none → essex-2
Julien Danjou (jdanjou) wrote :

I vigorously disagree with you here:

1. Every component in OpenStack support a -N option to the run_tests.sh scripts, and works perfectly.
2. If you don't support this flag, you should not announce it.
3. This flag is very useful for us packagers, because it allows us to run the test suite in the package building to check that the dependencies available in the distribution are making the tests valids, or not. Using a virtual env would be useless in such a case.

summary: - run_test.sh does not work without virtualenv
+ -N argument to run_test.sh does not work as specified
Gabriel Hurley (gabriel-hurley) wrote :

I can understand that point, and I now see that the flag should be respected in the run_tests. sh script. I've edited the title to make it a little more obvious that this is actually a bug. In the future, a more thorough bug report would be helpful.

For reference, because Horizon has unique challenges with dependency management due to our interactions with numerous OpenStack client libraries that change in unreliable ways, we've have had to heavily customize the run_tests.sh script where other OpenStack projects have not. It should be relatively easy to get that flag working again, though. Sorry for the misunderstanding.

Changed in horizon:
status: Invalid → Confirmed

Reviewed: https://review.openstack.org/2263
Committed: http://github.com/openstack/horizon/commit/c63d0973fa35d83b4f8be679236ec1acd7536879
Submitter: Jenkins
Branch: master

 status fixcommitted
 done

commit c63d0973fa35d83b4f8be679236ec1acd7536879
Author: Gabriel Hurley <email address hidden>
Date: Mon Dec 12 11:34:42 2011 -0800

    Testing improvements.

    Fixes bug 903349 -- sets socket timeout and overrides httplib2 connection
    method so that escaping external URI calls don't sit around forever.

    Fixes bug 894776 -- run_tests.sh properly respects the -N flag again.

    Change-Id: I979f49f065021cb91d8b9d01b6a36f78de1897df

Changed in horizon:
status: Confirmed → Fix Committed
Thierry Carrez (ttx) on 2011-12-14
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in horizon:
milestone: essex-2 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers