Containers can't list folder that uploaded by Cyberduck

Bug #889564 reported by eugene lin on 2011-11-12
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Medium
Gabriel Hurley

Bug Description

Hi ,developers.
Because horizon can't upload floder throgh web page.
I use Cyberduck to upload a floder successfully at win7 ,
and then click the horizon page ' List Objects' button ,
but meets follow problems:

TemplateSyntaxError at /dash/7/containers/lyq/

Caught NoReverseMatch while rendering: Reverse for 'dash_object_copy' with arguments '(u'7', u'lyq', u'new floder/file1.txt')' and keyword arguments '{}' not found.

eugene lin (linyouqing7) on 2011-11-13
description: updated
Gabriel Hurley (gabriel-hurley) wrote :

The URLpattern for reversing the copy and download links can't handle slashes in the filename. Slashes are also a special reserved character for denoting heirarchy in Swift. We should add a regex validator to the name input to prevent slashes from being added.

Support for multi-file uploads and swift pseudo-folders will both be added in the future and are tracked under separate tickets.

Changed in horizon:
assignee: nobody → Gabriel Hurley (gabriel-hurley)
status: New → Confirmed
description: updated
Devin Carlen (devcamcar) on 2011-12-17
Changed in horizon:
milestone: none → essex-4
importance: Undecided → Medium
Devin Carlen (devcamcar) on 2012-01-27
summary: - Containers can't list floder that uploaded by Cyberduck
+ Containers can't list folder that uploaded by Cyberduck

Fix proposed to branch: master
Review: https://review.openstack.org/4521

Changed in horizon:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/4521
Committed: http://github.com/openstack/horizon/commit/ab35449e4c24c811ef81a3626698d40d886a1f58
Submitter: Jenkins
Branch: master

commit ab35449e4c24c811ef81a3626698d40d886a1f58
Author: Gabriel Hurley <email address hidden>
Date: Thu Feb 23 17:10:29 2012 -0800

    Swift name usage cleanup. Unicode support and slash prohibition.

    Ensures end-to-end support for unicode characters w/ swift in all
    places where cloudfiles supports it. (patch submitted to fix cloudfiles).

    Also makes sure that the forward-slash character is not allowed in
    container or object names since it's a reserved character in swift.

    Fixes bug 889564 and fixes bug 940689.

    Change-Id: I259eb04f2f8854d43d1df28876d34b237a21fa9a

Changed in horizon:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-02-29
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in horizon:
milestone: essex-4 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers