Tenant switch list shouldn't change when on syspanel tenants panel

Bug #887767 reported by Gabriel Hurley on 2011-11-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
High
Gabriel Hurley

Bug Description

There's been a long-standing bug where the tenants switcher would list tenants that the user was not authorized for when looking at the Tenants or Users syspanel pages. This was due to which management url was used to fetch data on the page, plus a set of conflicting variable names. We can fix this.

Devin Carlen (devcamcar) on 2011-11-08
Changed in horizon:
status: New → Confirmed
importance: Undecided → High
milestone: none → essex-1
Changed in horizon:
status: Confirmed → Fix Committed
assignee: nobody → Gabriel Hurley (gabriel-hurley)
Thierry Carrez (ttx) on 2011-11-17
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in horizon:
milestone: essex-1 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers