tenant_id in url not enforced/checked

Bug #879111 reported by Gabriel Hurley on 2011-10-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Critical
Gabriel Hurley

Bug Description

Currently you can enter any arbitrary number in the url where the tenant id goes, and it does absolutely nothing. Valid tenant id or invalid doesn't matter, data displayed on the page is always the same (because it uses request.user.tenant_id, not the url param).

Changed in horizon:
status: New → Confirmed
Devin Carlen (devcamcar) on 2011-10-20
Changed in horizon:
importance: Undecided → Critical
milestone: none → essex-2

Reviewed: https://review.openstack.org/1317
Committed: http://github.com/openstack/horizon/commit/9742842795e964c7f260aec831665d5cb28cd420
Submitter: Jenkins
Branch: master

 status fixcommitted
 done

commit 9742842795e964c7f260aec831665d5cb28cd420
Author: Gabriel Hurley <email address hidden>
Date: Mon Oct 31 11:31:05 2011 -0700

    Re-architects the OpenStack Dashboard for modularity and extensibility.

    Implements blueprint extensible-architecture.
    Implements blueprint improve-dev-documentation.
    Implements blueprint gettext-everywhere.
    Implements blueprint sphinx-docs.

    Complete re-architecture of the dashboard to transform it from a standalone django-openstack app to a Horizon framework for building dashboards. See the docs for more information.

    Incidentally fixes the following bugs:

    Fixes bug 845868 -- no PEP8 violations.
    Fixes bug 766096 -- the dashboard can now be installed at any arbitrary URL.
    Fixes bug 879111 -- tenant id is now controlled solely by the tenant switcher, not the url (which was disregarded anyway)
    Fixes bug 794754 -- output of venv installation is considerably reduced.

    Due to the scale and scope of this patch I recommend reviewing it on github: https://github.com/gabrielhurley/horizon/tree/extensible_architecture

    Change-Id: I8e63f7ea235f904247df40c33cb66338d973df9e

Changed in horizon:
status: Confirmed → Fix Committed
Changed in horizon:
assignee: nobody → Gabriel Hurley (gabriel-hurley)
Thierry Carrez (ttx) on 2011-12-14
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in horizon:
milestone: essex-2 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers