Improve PEP8 violations in dashboard

Bug #845868 reported by Joseph Heck on 2011-09-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Wishlist
Gabriel Hurley

Bug Description

Dashboard is building and reporting PEP8 violations now at

https://jenkins.openstack.org/view/Dashboard/job/dashboard-pep8/

Current score is 162. It should be 0. Need to improve the PEP8 "score" to conform to Openstack standards

Devin Carlen (devcamcar) on 2011-09-19
Changed in openstack-dashboard:
status: New → Confirmed
importance: Undecided → Wishlist

Reviewed: https://review.openstack.org/1317
Committed: http://github.com/openstack/horizon/commit/9742842795e964c7f260aec831665d5cb28cd420
Submitter: Jenkins
Branch: master

 status fixcommitted
 done

commit 9742842795e964c7f260aec831665d5cb28cd420
Author: Gabriel Hurley <email address hidden>
Date: Mon Oct 31 11:31:05 2011 -0700

    Re-architects the OpenStack Dashboard for modularity and extensibility.

    Implements blueprint extensible-architecture.
    Implements blueprint improve-dev-documentation.
    Implements blueprint gettext-everywhere.
    Implements blueprint sphinx-docs.

    Complete re-architecture of the dashboard to transform it from a standalone django-openstack app to a Horizon framework for building dashboards. See the docs for more information.

    Incidentally fixes the following bugs:

    Fixes bug 845868 -- no PEP8 violations.
    Fixes bug 766096 -- the dashboard can now be installed at any arbitrary URL.
    Fixes bug 879111 -- tenant id is now controlled solely by the tenant switcher, not the url (which was disregarded anyway)
    Fixes bug 794754 -- output of venv installation is considerably reduced.

    Due to the scale and scope of this patch I recommend reviewing it on github: https://github.com/gabrielhurley/horizon/tree/extensible_architecture

    Change-Id: I8e63f7ea235f904247df40c33cb66338d973df9e

Changed in horizon:
status: Confirmed → Fix Committed
Thierry Carrez (ttx) on 2011-11-09
Changed in horizon:
milestone: none → essex-1
Changed in horizon:
assignee: nobody → Gabriel Hurley (gabriel-hurley)
Thierry Carrez (ttx) on 2011-11-17
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in horizon:
milestone: essex-1 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers