Horizon not show flavor details in instance and resize is not possible - Flavor ID is not supported by nova

Bug #1940834 reported by lmercl
152
This bug affects 30 people
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Fix Released
High
Vadym Markov
Ubuntu Cloud Archive
Fix Released
Undecided
Unassigned
Ussuri
Fix Released
High
Unassigned
Victoria
Fix Released
High
Unassigned
Wallaby
Fix Released
High
Unassigned
Xena
Fix Released
High
Unassigned
horizon (Ubuntu)
Fix Released
Undecided
Unassigned
Focal
Fix Released
High
Unassigned
Impish
Fix Released
High
Unassigned

Bug Description

In horizon on Wallaby and Victoria release, there are some view and function which are using ID value from Instance's Flavor part of JSON. The main issue is when you want to resize instance, you are receiving output below. The issue is also on Instance detail is specs, where Flavor is Not available. But on all instances view, this is working fine and base on detail of instance object and it's details, it looks like this view is using different methods based on older API.

We are running Wallaby dashboard with openstack-helm project with nova-api 2.88
Nova version:
{"versions": [{"id": "v2.0", "status": "SUPPORTED", "version": "", "min_version": "", "updated": "2011-01-21T11:33:21Z", "links": [{"rel": "self", "href": "http://nova.openstack.svc.cluster.local/v2/"}]}, {"id": "v2.1", "status": "CURRENT", "version": "2.88", "min_version": "2.1", "updated": "2013-07-23T11:33:21Z", "links": [{"rel": "self", "href": "http://nova.openstack.svc.cluster.local/v2.1/"}]}]})

For example for resize initialization the log output is:

2021-08-23 12:20:30.308473 Internal Server Error: /project/instances/a872bcc6-0a56-413a-9bea-b27dc006c707/resize
2021-08-23 12:20:30.308500 Traceback (most recent call last):
2021-08-23 12:20:30.308503 File "/var/lib/openstack/lib/python3.6/site-packages/horizon/utils/memoized.py", line 107, in wrapped
2021-08-23 12:20:30.308505 value = cache[key] = cache.pop(key)
2021-08-23 12:20:30.308507 KeyError: ((<weakref at 0x7fba91b35228; to 'ResizeView' at 0x7fba91b407b8>,), ())
2021-08-23 12:20:30.308509
2021-08-23 12:20:30.308512 During handling of the above exception, another exception occurred:
2021-08-23 12:20:30.308513
2021-08-23 12:20:30.308515 Traceback (most recent call last):
2021-08-23 12:20:30.308517 File "/var/lib/openstack/lib/python3.6/site-packages/django/core/handlers/exception.py", line 34, in inner
2021-08-23 12:20:30.308519 response = get_response(request)
2021-08-23 12:20:30.308521 File "/var/lib/openstack/lib/python3.6/site-packages/django/core/handlers/base.py", line 115, in _get_response
2021-08-23 12:20:30.308523 response = self.process_exception_by_middleware(e, request)
2021-08-23 12:20:30.308525 File "/var/lib/openstack/lib/python3.6/site-packages/django/core/handlers/base.py", line 113, in _get_response
2021-08-23 12:20:30.308527 response = wrapped_callback(request, *callback_args, **callback_kwargs)
2021-08-23 12:20:30.308529 File "/var/lib/openstack/lib/python3.6/site-packages/horizon/decorators.py", line 52, in dec
2021-08-23 12:20:30.308531 return view_func(request, *args, **kwargs)
2021-08-23 12:20:30.308533 File "/var/lib/openstack/lib/python3.6/site-packages/horizon/decorators.py", line 36, in dec
2021-08-23 12:20:30.308534 return view_func(request, *args, **kwargs)
2021-08-23 12:20:30.308536 File "/var/lib/openstack/lib/python3.6/site-packages/horizon/decorators.py", line 36, in dec
2021-08-23 12:20:30.308538 return view_func(request, *args, **kwargs)
2021-08-23 12:20:30.308540 File "/var/lib/openstack/lib/python3.6/site-packages/horizon/decorators.py", line 112, in dec
2021-08-23 12:20:30.308542 return view_func(request, *args, **kwargs)
2021-08-23 12:20:30.308543 File "/var/lib/openstack/lib/python3.6/site-packages/horizon/decorators.py", line 84, in dec
2021-08-23 12:20:30.308545 return view_func(request, *args, **kwargs)
2021-08-23 12:20:30.308547 File "/var/lib/openstack/lib/python3.6/site-packages/django/views/generic/base.py", line 71, in view
2021-08-23 12:20:30.308549 return self.dispatch(request, *args, **kwargs)
2021-08-23 12:20:30.308551 File "/var/lib/openstack/lib/python3.6/site-packages/django/views/generic/base.py", line 97, in dispatch
2021-08-23 12:20:30.308553 return handler(request, *args, **kwargs)
2021-08-23 12:20:30.308554 File "/var/lib/openstack/lib/python3.6/site-packages/horizon/workflows/views.py", line 153, in get
2021-08-23 12:20:30.308556 context = self.get_context_data(**kwargs)
2021-08-23 12:20:30.308559 File "/var/lib/openstack/lib/python3.6/site-packages/openstack_dashboard/dashboards/project/instances/views.py", line 597, in get_context_data
2021-08-23 12:20:30.308561 context = super().get_context_data(**kwargs)
2021-08-23 12:20:30.308563 File "/var/lib/openstack/lib/python3.6/site-packages/horizon/workflows/views.py", line 91, in get_context_data
2021-08-23 12:20:30.308565 workflow = self.get_workflow()
2021-08-23 12:20:30.308567 File "/var/lib/openstack/lib/python3.6/site-packages/horizon/workflows/views.py", line 77, in get_workflow
2021-08-23 12:20:30.308570 extra_context = self.get_initial()
2021-08-23 12:20:30.308571 File "/var/lib/openstack/lib/python3.6/site-packages/openstack_dashboard/dashboards/project/instances/views.py", line 638, in get_initial
2021-08-23 12:20:30.308573 _object = self.get_object()
2021-08-23 12:20:30.308575 File "/var/lib/openstack/lib/python3.6/site-packages/horizon/utils/memoized.py", line 109, in wrapped
2021-08-23 12:20:30.308577 value = cache[key] = func(*args, **kwargs)
2021-08-23 12:20:30.308578 File "/var/lib/openstack/lib/python3.6/site-packages/openstack_dashboard/dashboards/project/instances/views.py", line 610, in get_object
2021-08-23 12:20:30.308583 flavor_id = instance.flavor['id']
2021-08-23 12:20:30.308586 KeyError: 'id'

For older version e.g. by this command:
curl -s -H "X-Auth-Token: $OS_TOKEN" -H "X-OpenStack-Nova-API-Version: 2.46" "http://nova-api:8774/v2.1/servers/{some server ID}" | python -mjson.tool

        "flavor": {
            "id": "2",
            "links": [
                {
                    "href": "http://xxx.xxx.xxx.xxx:30774/flavors/2",
                    "rel": "bookmark"
                }
            ]
        }

For current and >=2.47
curl -s -H "X-Auth-Token: $OS_TOKEN" -H "X-OpenStack-Nova-API-Version: 2.46" "http://nova-api:8774/v2.1/servers/{some server ID}" | python -mjson.tool

        "flavor": {
            "disk": 20,
            "ephemeral": 0,
            "extra_specs": {},
            "original_name": "m1.small",
            "ram": 2048,
            "swap": 0,
            "vcpus": 1
        }

This change in Nova is described:
https://specs.openstack.org/openstack/nova-specs/specs/pike/implemented/instance-flavor-api.html

Steps for reproduce:
1) init resize on Wallaby release with nova-api larger then 2.47

We are running the Horizon based on e.g. openstackhelm/horizon:wallaby-ubuntu_focal-20210823
with these versions:
python-cinderclient==7.4.0
python-dateutil==2.8.1
python-glanceclient==3.3.0
python-heatclient==2.3.0
python-keystoneclient==4.2.0
python-memcached==1.59
python-neutronclient==7.3.0
python-novaclient==17.4.0
python-swiftclient==3.11.1
openstacksdk==0.55.0

**************************************************************
SRU Information:

== Begin SRU Template ==
[Impact]
Not possible to resize an instance from OpenStack dashbaord.

[Test Case]

1. Login to OpenStack dashboard
2. Click on Project -> Compute -> Instances
3. Select an instance and click on "Resize Instance" in Actions column.
   A popup should appear asking for New Flavor.

[Regression Potential]
In order to mitigate the regression potential, selenium tests are added as
part of patch which tests different Nova API versions.

lmercl (lmercl)
description: updated
Revision history for this message
Vadym Markov (vmarkov) wrote :

Working on issue. Problem started since Nova API v2.47 (introduced about Pike), which changed flavor response format

Changed in horizon:
status: New → Confirmed
assignee: nobody → Vadym Markov (vmarkov)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to horizon (master)

Fix proposed to branch: master
Review: https://review.opendev.org/c/openstack/horizon/+/808102

Changed in horizon:
status: Confirmed → In Progress
Revision history for this message
Gaël THEROND (fl1nt) wrote :

Thanks to your report, I'm having the exact same issue on Ussuri where everything worked fine on Train with a nova API > 2.46

I'm wondering if there is some edgy cases that make it not working on Ussuri.
I Will dig deeper but all in all thanks for your patch it helped me to downstream fix our platform quickly while we were having our tempest and beta users reporting this issue back.

Revision history for this message
Lars Erik Pedersen (pedersen-larserik) wrote :

Hi! We're also having this issue on Ussuri. Exactly the same stacktrace as in the first post here.

python3-openstacksdk.noarch 0.46.0-1.el8
openstack-dashboard.noarch 1:18.3.4-1.el8
python3-novaclient.noarch 1:17.0.0-1.el8

Also, we're currently running Victorai in our test environment. It works fine there..
python3-openstacksdk.noarch 0.50.0-1.el8
openstack-dashboard.noarch 1:18.6.2-1.el8
python3-novaclient.noarch 1:17.2.1-1.el8

Bui Hong Ha (telescreen)
tags: added: sts
Revision history for this message
Facundo Ciccioli (fandanbango) wrote :

Adding field-high as we have a customer affected by this issue.

Revision history for this message
hard (ihard) wrote :

I have same problem with Xena release:

dpkg -l | grep -E 'opensta|nova'
ii openstack-dashboard 4:20.1.0-0ubuntu1~cloud0 all Django web interface for OpenStack
ii openstack-dashboard-common 4:20.1.0-0ubuntu1~cloud0 all Django web interface for OpenStack - common files
ii python3-django-openstack-auth 4:20.1.0-0ubuntu1~cloud0 all Django authentication backend for Openstack - Python 3
ii python3-novaclient 2:17.6.0-0ubuntu1~cloud0 all client library for OpenStack Compute API - 3.x
ii python3-openstacksdk 0.59.0-0ubuntu1~cloud0 all SDK for building applications to work with OpenStack - Python 3.x

Changed in horizon:
importance: Undecided → High
Revision history for this message
Akihiro Motoki (amotoki) wrote :

The affected versions are: ussuri, victoria, wallaby, xena and master (yoga).

This issue was caused by commit 64fe0abb653950c85d455dedd09ef42856c6b07b (in the master branch) [1]. This commit touched the microversions used when server_get() is called. It was backported to wallaby, victoria and ussuri stable branches.

[1] https://review.opendev.org/q/Ic8330b947b1a733f70c3bdad8b3493f20a2f26fb

tags: added: ussuri-backport-potential victoria-backport-potential wallaby-backport-potential xena-backport-potential
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to horizon (master)

Reviewed: https://review.opendev.org/c/openstack/horizon/+/808102
Committed: https://opendev.org/openstack/horizon/commit/d269b1640f49e13aa1693a175083d66a3eaf5386
Submitter: "Zuul (22348)"
Branch: master

commit d269b1640f49e13aa1693a175083d66a3eaf5386
Author: Vadym Markov <email address hidden>
Date: Thu Sep 9 17:52:40 2021 +0300

    Fix for "Resize instance" button

    Currently, "Resize instance" widget is not working because it relies on
    legacy Nova API v2.46, obsoleted in Pike release. Proposed patch make
    Horizon use current Nova API (>=2.47).

    Closes-Bug: #1940834
    Co-Authored-By: Akihiro Motoki <email address hidden>
    Change-Id: Id2f38acfc27cdf93cc4341422873e512aaff716a

Changed in horizon:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to horizon (stable/xena)

Fix proposed to branch: stable/xena
Review: https://review.opendev.org/c/openstack/horizon/+/829662

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to horizon (stable/wallaby)

Fix proposed to branch: stable/wallaby
Review: https://review.opendev.org/c/openstack/horizon/+/829663

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to horizon (stable/victoria)

Fix proposed to branch: stable/victoria
Review: https://review.opendev.org/c/openstack/horizon/+/829686

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to horizon (stable/ussuri)

Fix proposed to branch: stable/ussuri
Review: https://review.opendev.org/c/openstack/horizon/+/829706

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix proposed to horizon (master)

Related fix proposed to branch: master
Review: https://review.opendev.org/c/openstack/horizon/+/830630

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix merged to horizon (master)

Reviewed: https://review.opendev.org/c/openstack/horizon/+/830630
Committed: https://opendev.org/openstack/horizon/commit/a7956cd0043e6c58d121e536ed8ace0abd0e2522
Submitter: "Zuul (22348)"
Branch: master

commit a7956cd0043e6c58d121e536ed8ace0abd0e2522
Author: Akihiro Motoki <email address hidden>
Date: Thu Feb 24 00:26:47 2022 +0900

    Avoid extra flavor_get in resize server form

    commit d269b1640f49e13aa1693a175083d66a3eaf5386 fixes the bug on
    the resize server form, but it introduced an extra flavor_get call
    even when we retrieve the list of flavors. This commit recovers
    the previous behavior that we first looks up the list of flavors.

    Related-Bug: #1940834
    Change-Id: I891aa6b8652f330326535732d0886362dfabb989

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to horizon (stable/xena)

Reviewed: https://review.opendev.org/c/openstack/horizon/+/829662
Committed: https://opendev.org/openstack/horizon/commit/4f4e8800904dc98a696c5aebe3ffcc947e2deabc
Submitter: "Zuul (22348)"
Branch: stable/xena

commit 4f4e8800904dc98a696c5aebe3ffcc947e2deabc
Author: Thomas Goirand <email address hidden>
Date: Thu Feb 17 10:36:31 2022 +0100

    Fix for "Resize instance" button

    Currently, "Resize instance" widget is not working because it relies on
    legacy Nova API v2.46, obsoleted in Pike release. Proposed patch make
    Horizon use current Nova API (>=2.47).

    Note: It also cherry-picks a7956cd004 from the master branch
    which avoids the extra call of flavor_get in resize server form.

    Closes-Bug: #1940834
    Co-Authored-By: Akihiro Motoki <email address hidden>
    Change-Id: Id2f38acfc27cdf93cc4341422873e512aaff716a

tags: added: in-stable-xena
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to horizon (stable/wallaby)

Reviewed: https://review.opendev.org/c/openstack/horizon/+/829663
Committed: https://opendev.org/openstack/horizon/commit/89e3e51e5f4bd61268c218caf502718870b44019
Submitter: "Zuul (22348)"
Branch: stable/wallaby

commit 89e3e51e5f4bd61268c218caf502718870b44019
Author: Thomas Goirand <email address hidden>
Date: Thu Feb 17 10:36:31 2022 +0100

    Fix for "Resize instance" button

    Currently, "Resize instance" widget is not working because it relies on
    legacy Nova API v2.46, obsoleted in Pike release. Proposed patch make
    Horizon use current Nova API (>=2.47).

    Note: It also cherry-picks a7956cd004 from the master branch
    which avoids the extra call of flavor_get in resize server form.

    Closes-Bug: #1940834
    Co-Authored-By: Akihiro Motoki <email address hidden>
    Change-Id: Id2f38acfc27cdf93cc4341422873e512aaff716a
    (cherry picked from commit 4f4e8800904dc98a696c5aebe3ffcc947e2deabc)

tags: added: in-stable-wallaby
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/horizon 22.0.0

This issue was fixed in the openstack/horizon 22.0.0 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to horizon (stable/victoria)

Reviewed: https://review.opendev.org/c/openstack/horizon/+/829686
Committed: https://opendev.org/openstack/horizon/commit/41cb811865a335626e7a14282e5223fa8d09379a
Submitter: "Zuul (22348)"
Branch: stable/victoria

commit 41cb811865a335626e7a14282e5223fa8d09379a
Author: Thomas Goirand <email address hidden>
Date: Thu Feb 17 10:36:31 2022 +0100

    Fix for "Resize instance" button

    Currently, "Resize instance" widget is not working because it relies on
    legacy Nova API v2.46, obsoleted in Pike release. Proposed patch make
    Horizon use current Nova API (>=2.47).

    Note: It also cherry-picks a7956cd004 from the master branch
    which avoids the extra call of flavor_get in resize server form.

    Closes-Bug: #1940834
    Co-Authored-By: Akihiro Motoki <email address hidden>
    Change-Id: Id2f38acfc27cdf93cc4341422873e512aaff716a
    (cherry picked from commit d269b1640f49e13aa1693a175083d66a3eaf5386)

tags: added: in-stable-victoria
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to horizon (stable/ussuri)

Reviewed: https://review.opendev.org/c/openstack/horizon/+/829706
Committed: https://opendev.org/openstack/horizon/commit/920cbb82d20be33074eec52abc6022f5ff97e569
Submitter: "Zuul (22348)"
Branch: stable/ussuri

commit 920cbb82d20be33074eec52abc6022f5ff97e569
Author: Thomas Goirand <email address hidden>
Date: Thu Feb 17 10:36:31 2022 +0100

    Fix for "Resize instance" button

    Currently, "Resize instance" widget is not working because it relies on
    legacy Nova API v2.46, obsoleted in Pike release. Proposed patch make
    Horizon use current Nova API (>=2.47).

    Note: It also cherry-picks a7956cd004 from the master branch
    which avoids the extra call of flavor_get in resize server form.

    Closes-Bug: #1940834
    Co-Authored-By: Akihiro Motoki <email address hidden>
    Change-Id: Id2f38acfc27cdf93cc4341422873e512aaff716a
    (cherry picked from commit d269b1640f49e13aa1693a175083d66a3eaf5386)

tags: added: in-stable-ussuri
description: updated
Changed in horizon (Ubuntu):
milestone: none → focal-updates
milestone: focal-updates → none
tags: added: sts-sru-needed
Revision history for this message
Hemanth Nakkina (hemanth-n) wrote :
Revision history for this message
Hemanth Nakkina (hemanth-n) wrote :
Revision history for this message
Hemanth Nakkina (hemanth-n) wrote :
Revision history for this message
Hemanth Nakkina (hemanth-n) wrote :
Revision history for this message
Hemanth Nakkina (hemanth-n) wrote :
Revision history for this message
Hemanth Nakkina (hemanth-n) wrote :
Revision history for this message
Hemanth Nakkina (hemanth-n) wrote :

Hi SRU team,

Debdiff's for Impish/Focal, UCA xena/wallaby/victoria/ussuri are attached.

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "Debdiff for impish" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in horizon (Ubuntu Focal):
status: New → Confirmed
Changed in horizon (Ubuntu Impish):
status: New → Confirmed
Changed in horizon (Ubuntu):
status: New → Confirmed
Changed in cloud-archive:
status: New → Fix Released
Changed in horizon (Ubuntu):
status: Confirmed → Fix Released
Changed in horizon (Ubuntu Focal):
status: Confirmed → Triaged
importance: Undecided → High
Changed in horizon (Ubuntu Impish):
status: Confirmed → Triaged
importance: Undecided → High
Revision history for this message
Corey Bryant (corey.bryant) wrote :

Uploaded to impish and focal unapproved queues, as well as wallaby-staging and victoria-staging.

Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello lmercl, or anyone else affected,

Accepted horizon into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/horizon/3:18.3.5-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in horizon (Ubuntu Focal):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-focal
Revision history for this message
Brian Murray (brian-murray) wrote :

I did not accept this for impish because there is a pending SRU for the horizon package for that release.

Revision history for this message
Corey Bryant (corey.bryant) wrote :

Hello lmercl, or anyone else affected,

Accepted horizon into ussuri-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:ussuri-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-ussuri-needed to verification-ussuri-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-ussuri-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-ussuri-needed
Revision history for this message
Hemanth Nakkina (hemanth-n) wrote :

Verified on focal and UCA ussuri and resize works fine on dhasboard with -proposed.

Tested packages:
focal openstack-dashboard 3:18.3.5-0ubuntu2
UCA ussuri openstack-dashboard 3:18.3.5-0ubuntu2~cloud0

tags: added: verification-done-focal verification-ussuri-done
removed: verification-needed-focal verification-ussuri-needed
Revision history for this message
Robie Basak (racb) wrote :

What's the plan for Impish? See comment 33. If this is released to Focal but not Impish, then users would face a regression when upgrading from Focal to Impish.

Revision history for this message
Edward Hope-Morley (hopem) wrote :

Impish currently has https://bugs.launchpad.net/cloud-archive/+bug/1962582 in its queue which will need to be released before the Xena backport (already in unapproved queue for I) can be approves (and this patch is not yet in an upstream PR hence why an SRU is needed).

Revision history for this message
Brian Murray (brian-murray) wrote :

The version of horizon which was in -proposed for Impish was released today.

Revision history for this message
Brian Murray (brian-murray) wrote :

Hello lmercl, or anyone else affected,

Accepted horizon into impish-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/horizon/4:20.1.1-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-impish to verification-done-impish. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-impish. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in horizon (Ubuntu Impish):
status: Triaged → Fix Committed
tags: added: verification-needed-impish
Revision history for this message
Hemanth Nakkina (hemanth-n) wrote :

Verified on impish and resize works fine on dashboard with -proposed.

Tested packages:
impish openstack-dashboard 4:20.1.1-0ubuntu2

tags: added: verification-done-impish
removed: verification-needed-impish
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to horizon (stable/train)

Fix proposed to branch: stable/train
Review: https://review.opendev.org/c/openstack/horizon/+/838533

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/horizon 18.6.4

This issue was fixed in the openstack/horizon 18.6.4 release.

Revision history for this message
Chris Halse Rogers (raof) wrote : Update Released

The verification of the Stable Release Update for horizon has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package horizon - 4:20.1.1-0ubuntu2

---------------
horizon (4:20.1.1-0ubuntu2) impish; urgency=medium

  * d/p/0001-Fix-for-Resize-instance-button.patch: Fixes resize instance
    widget (LP: #1940834).

 -- Hemanth Nakkina <email address hidden> Thu, 24 Mar 2022 09:58:48 +0530

Changed in horizon (Ubuntu Impish):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package horizon - 3:18.3.5-0ubuntu2

---------------
horizon (3:18.3.5-0ubuntu2) focal; urgency=medium

  * d/p/0001-Fix-for-Resize-instance-button.patch: Fixes resize instance
    widget (LP: #1940834).

 -- Hemanth Nakkina <email address hidden> Thu, 24 Mar 2022 09:41:06 +0530

Changed in horizon (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to horizon (stable/train)

Reviewed: https://review.opendev.org/c/openstack/horizon/+/838533
Committed: https://opendev.org/openstack/horizon/commit/724005ca275e820d2850feba3139c058d7d07958
Submitter: "Zuul (22348)"
Branch: stable/train

commit 724005ca275e820d2850feba3139c058d7d07958
Author: Thomas Goirand <email address hidden>
Date: Thu Feb 17 10:36:31 2022 +0100

    Fix for "Resize instance" button

    Currently, "Resize instance" widget is not working because it relies on
    legacy Nova API v2.46, obsoleted in Pike release. Proposed patch make
    Horizon use current Nova API (>=2.47).

    Note: It also cherry-picks a7956cd004 from the master branch
    which avoids the extra call of flavor_get in resize server form.

    Closes-Bug: #1940834
    Co-Authored-By: Akihiro Motoki <email address hidden>
    Change-Id: Id2f38acfc27cdf93cc4341422873e512aaff716a
    (cherry picked from commit d269b1640f49e13aa1693a175083d66a3eaf5386)
    (cherry picked from commit 920cbb82d20be33074eec52abc6022f5ff97e569)

tags: added: in-stable-train
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/horizon 20.1.2

This issue was fixed in the openstack/horizon 20.1.2 release.

Revision history for this message
Garrett Thompson (thogarre) wrote :

Hello, it looks like the verification-done-ussuri tag was added for the backport to ussuri-proposed on March 30th, is there any pending work before this can be backported to ussuri/stable? Thanks for your time!

Revision history for this message
Corey Bryant (corey.bryant) wrote : Please test proposed package

Hello lmercl, or anyone else affected,

Accepted horizon into victoria-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:victoria-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-victoria-needed to verification-victoria-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-victoria-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-victoria-needed
Revision history for this message
Corey Bryant (corey.bryant) wrote :

Hello lmercl, or anyone else affected,

Accepted horizon into wallaby-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:wallaby-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-wallaby-needed to verification-wallaby-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-wallaby-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-wallaby-needed
Revision history for this message
Corey Bryant (corey.bryant) wrote :

Hello lmercl, or anyone else affected,

Accepted horizon into xena-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:xena-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-xena-needed to verification-xena-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-xena-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-xena-needed
Revision history for this message
Hemanth Nakkina (hemanth-n) wrote :

Verified on UCA xena, wallaby, victoria and resize works fine on dashboard with -proposed.

Tested packages:
xena openstack-dashboard 4:20.1.1-0ubuntu2~cloud0
wallaby openstack-dashboard 4:19.2.0-0ubuntu1~cloud1
victoria openstack-dashboard 4:18.6.3-0ubuntu1~cloud1

tags: added: verification-done verification-victoria-done verification-wallaby-done verification-xena-done
removed: verification-needed verification-victoria-needed verification-wallaby-needed verification-xena-needed
Revision history for this message
Corey Bryant (corey.bryant) wrote : Update Released

The verification of the Stable Release Update for horizon has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package horizon - 4:20.1.1-0ubuntu2~cloud0
---------------

 horizon (4:20.1.1-0ubuntu2~cloud0) focal-xena; urgency=medium
 .
   * New update for the Ubuntu Cloud Archive.
 .
 horizon (4:20.1.1-0ubuntu2) impish; urgency=medium
 .
   * d/p/0001-Fix-for-Resize-instance-button.patch: Fixes resize instance
     widget (LP: #1940834).

Revision history for this message
Corey Bryant (corey.bryant) wrote :

The verification of the Stable Release Update for horizon has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package horizon - 4:19.2.0-0ubuntu1~cloud1
---------------

 horizon (4:19.2.0-0ubuntu1~cloud1) focal-wallaby; urgency=medium
 .
   [ Corey Bryant ]
   * d/gbp.conf: Create stable/wallaby branch.
 .
   [ Hemanth Nakkina ]
   * d/p/0001-Fix-for-Resize-instance-button.patch: Fixes resize instance
     widget (LP: #1940834).

Revision history for this message
Corey Bryant (corey.bryant) wrote :

The verification of the Stable Release Update for horizon has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package horizon - 4:18.6.3-0ubuntu1~cloud1
---------------

 horizon (4:18.6.3-0ubuntu1~cloud1) focal-victoria; urgency=medium
 .
   * d/p/0001-Fix-for-Resize-instance-button.patch: Fixes resize instance
     widget (LP: #1940834).

Revision history for this message
James Page (james-page) wrote :

The verification of the Stable Release Update for horizon has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
James Page (james-page) wrote :

This bug was fixed in the package horizon - 3:18.3.5-0ubuntu2~cloud0
---------------

 horizon (3:18.3.5-0ubuntu2~cloud0) bionic-ussuri; urgency=medium
 .
   * New update for the Ubuntu Cloud Archive.
 .
 horizon (3:18.3.5-0ubuntu2) focal; urgency=medium
 .
   * d/p/0001-Fix-for-Resize-instance-button.patch: Fixes resize instance
     widget (LP: #1940834).

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/horizon 19.3.0

This issue was fixed in the openstack/horizon 19.3.0 release.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers