Support for Angular 1.8.x in Horizon

Bug #1927261 reported by Vishal Manchanda
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
New
Undecided
Vishal Manchanda

Bug Description

Some of the horizon angular panels (keypair and glance) are broken in Debian Bullseye distribution.
As of now, we use angular 1.5.8.0 in the horizon [1], [2], [3].
We can try to update angularjs to 1.8.2 maybe that fixes the issue.

[1] https://github.com/openstack/horizon/blob/master/requirements.txt#L44
[2] https://pypi.org/project/XStatic-Angular/
[3] https://opendev.org/openstack/requirements/src/branch/master/openstack_requirements/tests/files/upper-constraints.txt#L73

Related thread: http://lists.openstack.org/pipermail/openstack-discuss/2021-May/022243.html

Changed in horizon:
assignee: nobody → Vishal Manchanda (vishalmanchanda)
description: updated
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers