When open a link for the detal of image as 'Open Link in New Tab', the new tab doesn't show the details of image.

Bug #1902821 reported by Keigo Noha on 2020-11-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Medium
Tatiana Ovchinnikova

Bug Description

Description:
When open a link for the detal of image as 'Open Link in New Tab', the new tab doesn't show the details of image.

The page shows '{$ ctrl.itemName $}'

How to reproduce:
For example, an Image view in "Compute" -> "Image" shows a image list.
If a user tried to open a link whose name is an image name as 'Open Link in New tab' on any browser, the user will get a page which shows '{$ ctrl.itemName $}'.

This issue seems to happen on the URL which has '/ngdetails/XXX' only.

Akihiro Motoki (amotoki) on 2020-11-18
Changed in horizon:
status: New → Confirmed
importance: Undecided → Medium
Changed in horizon:
assignee: nobody → Vishal Manchanda (vishalmanchanda)
Tatiana Ovchinnikova (tmazur) wrote :

Weird, I cannot reproduce the bug. "Open Link in New Tab" generates the same redirect link '/ngdetails/OS::Glance::Image/XXX' as for the existing tab and content is the same as well.

Tatiana Ovchinnikova (tmazur) wrote :

Update: for Key Pairs it also works for me, but Server Groups page is affected indeed.

Changed in horizon:
assignee: Vishal Manchanda (vishalmanchanda) → Tatiana Ovchinnikova (tmazur)

Fix proposed to branch: master
Review: https://review.opendev.org/763293

Changed in horizon:
status: Confirmed → In Progress

yeah, it's strange because If I use devStack apache deployment of the horizon I got the same error for images and Key_Pairs, Server_Groups as well but If I used horizon development server then I got this error only for Server_Group.

Tatiana Ovchinnikova (tmazur) wrote :

Weird. Debugging the error at Server Groups page lead to the default index page missing, and Images and Key Pairs modules both have this property.

Akihiro Motoki (amotoki) wrote :

According to my small test, the difference between runserver and DevStack apache env is whether an additional parent path (/dashboard/ in case of DevStack apache env) exists or not.
When I change setDefaultIndexUrl in openstack_dashboard/static/app/core/images/images.module.js to '/project/images/' to '/dashboard/project/images/', the reported issue disappeared in DevStack apache env and started to appear in the runserver env.
From this result, it is apparent that setDefaultIndexUrl() does not WEBROOT in the horizon settings.
I think we need to update setDefaultIndexUrl() (or something other) to honor WEBROOT.

Note that Tatiana's fix above is related but I think it does not fix this bug.

(I dropped the same comment in the review)

Tatiana Ovchinnikova (tmazur) wrote :
Changed in horizon:
status: In Progress → Fix Released

This issue was fixed in the openstack/horizon 18.3.3 release.

This issue was fixed in the openstack/horizon 18.6.2 release.

This issue was fixed in the openstack/horizon 19.1.0 release.

This issue was fixed in the openstack/horizon 16.2.2 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers