Unable to use 'Any' availability zone when spawning instance

Bug #1613900 reported by sergiiF on 2016-08-16
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
High
Matt Borland
Ubuntu Cloud Archive
Undecided
Unassigned
Mitaka
High
Shane Peters
horizon (Ubuntu)
Undecided
Unassigned
Xenial
High
Shane Peters

Bug Description

[Impact]
While using Mitaka, we found that by default, using js backend, it is not possible to choose 'any' availability zone. The issue is not fixed in master branch.

For python implementation the logic is:
https://github.com/openstack/horizon/blob/master/openstack_dashboard/dashboards/project/instances/workflows/create_instance.py#L390

The JS implementation miss the logic if number of AZs is >1
https://github.com/openstack/horizon/blob/master/openstack_dashboard/dashboards/project/static/dashboard/project/workflow/launch-instance/launch-instance-model.service.js#L321

Also, JS implementation looks ugly if you have lot of subnets per network...

[Test Case]
Ensure that in the Angular Launch Instance, if there is more than one availability zone, it defaults to the option of Nova scheduler picking the AZ.

[Regression Potential]
Regression potential is fairly low. This bug has been fixed in all releases of OpenStack starting with Newton. The patch did have to be modified slightly to apply to mitaka.

Brad Pokorny (bpokorny) on 2016-08-16
Changed in horizon:
status: New → Confirmed
Matt Borland (palecrow) wrote :

We've experienced this bug as well. Looking into it.

Changed in horizon:
importance: Undecided → High

Fix proposed to branch: master
Review: https://review.openstack.org/362230

Changed in horizon:
assignee: nobody → Matt Borland (palecrow)
status: Confirmed → In Progress
David Lyle (david-lyle) on 2016-10-13
tags: added: angularjs newton-backport-potential

Reviewed: https://review.openstack.org/362230
Committed: https://git.openstack.org/cgit/openstack/horizon/commit/?id=be6bcef45289ce1a934db478e5c9c7705890af18
Submitter: Jenkins
Branch: master

commit be6bcef45289ce1a934db478e5c9c7705890af18
Author: Matt Borland <email address hidden>
Date: Mon Aug 29 09:54:56 2016 -0600

    Let Nova to pick availability zone if more than 1

    In the Angular Launch Instance, if there is more than one availability zone,
    default to the option for the Nova scheduler to pick. This is a regression
    from the legacy Launch Instance feature.

    If you want to simulate testing the logic with multiple avaiability zones,
    go to: .../launch-instance/launch-instance-model.service.js line 785 and add:

    model.availabilityZones.push({label: 'another one', value: 'another one'});

    Change-Id: Ib81447382bc9d43e33ce97f78c085d2a94ff2018
    Closes-Bug: 1613900

Changed in horizon:
status: In Progress → Fix Released
Changed in horizon:
milestone: none → ocata-2

This issue was fixed in the openstack/horizon 11.0.0.0b2 development milestone.

This issue was fixed in the openstack/horizon 10.0.2 release.

Change abandoned by Radomir Dopieralski (<email address hidden>) on branch: stable/mitaka
Review: https://review.openstack.org/426170
Reason: Let me just abandon this.

Shane Peters (shaner) on 2018-01-03
Changed in cloud-archive:
assignee: nobody → Shane Peters (shaner)
status: New → In Progress
Shane Peters (shaner) wrote :

Backport of patch to Mitaka for Ubuntu Cloud Archive.

Changed in horizon (Ubuntu):
assignee: nobody → Shane Peters (shaner)
status: New → In Progress
milestone: none → xenial-updates
tags: added: patch

The attachment "horizon_9.1.2-0ubuntu4.patch" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

Changed in horizon (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → High
Changed in horizon (Ubuntu):
status: In Progress → Invalid
Changed in cloud-archive:
status: In Progress → Invalid
Changed in horizon (Ubuntu Xenial):
assignee: nobody → Shane Peters (shaner)
Changed in cloud-archive:
assignee: Shane Peters (shaner) → nobody
Changed in horizon (Ubuntu):
assignee: Shane Peters (shaner) → nobody
Corey Bryant (corey.bryant) wrote :

Adding SRU details for Ubuntu.

[Impact]
See bug description above.

[Test Case]
Ensure that in the Angular Launch Instance, if there is more than one availability zone, it defaults to the option of Nova scheduler picking the AZ.

[Regression Potential]
Regression potential is fairly low. This bug has been fixed in all releases of OpenStack starting with Newton. The patch did have to be modified slightly to apply to mitaka.

[Discussion]

Corey Bryant (corey.bryant) wrote :

Thanks Shane. I've uploaded a new version of horizon with your patch to the xenial review queue where the SRU team will review.

Shane Peters (shaner) wrote :

Thanks Corey!

tags: added: sts
description: updated

Hello sergiiF, or anyone else affected,

Accepted horizon into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/horizon/2:9.1.2-0ubuntu4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in horizon (Ubuntu Xenial):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-xenial
Corey Bryant (corey.bryant) wrote :

Hello sergiiF, or anyone else affected,

Accepted horizon into mitaka-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:mitaka-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-mitaka-needed to verification-mitaka-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-mitaka-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-mitaka-needed
Shane Peters (shaner) on 2018-01-24
tags: added: verification-done verification-done-xenial verification-mitaka-done
removed: verification-mitaka-needed verification-needed verification-needed-xenial
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers