Unclear error message when user creates image with incorrect location url

Bug #1582128 reported by Timur Nurlygayanov on 2016-05-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Undecided
Unassigned

Bug Description

Steps To Reproduce:
1. Login to Horizon dashboard
2. Navigate to Project > Compute > Images
3. Click on "Create Image" button
4. Set name for this image = "test", Image Source = "Image Location", Image Location = "http://test2.com/this-image-doesn't-exists.qcow2", Format = "QCOW2"
5. Click on "Create Image"

Expected Result:
Horizon should validate the url and provide warning message about the incorrect url or at least show error message after "create image" dialog will be closed.

Observed Result:
The dialog window is active and we can see the following error on the background (and it is not clear why we can't create the image):
Error: Unable To Create New Image

Changed in horizon:
assignee: nobody → Marcellin Fom Tchassem (mf6510)
Changed in horizon:
assignee: Marcellin Fom Tchassem (mf6510) → nobody
Sirisha (sirisha-1) on 2016-05-20
Changed in horizon:
assignee: nobody → Sirisha (sirisha-1)

Fix proposed to branch: master
Review: https://review.openstack.org/319839

Changed in horizon:
status: New → In Progress

Change abandoned by Rob Cresswell (<email address hidden>) on branch: master
Review: https://review.openstack.org/319839
Reason: Abandoned due to inactivity

Changed in horizon:
assignee: Sirisha (sirisha-1) → nobody
status: In Progress → New
tags: added: low-hanging-fruit
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers