swift ui upload results in 0 byte files

Bug #1576422 reported by Richard Jones on 2016-04-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
High
Richard Jones

Bug Description

Current master file uploads in the swift ui result in 0 byte files in swift.

Changed in horizon:
milestone: none → newton-1
Timur Sufiev (tsufiev-x) on 2016-04-29
Changed in horizon:
status: New → Confirmed
importance: Undecided → High

Fix proposed to branch: master
Review: https://review.openstack.org/311178

Changed in horizon:
status: Confirmed → In Progress
tags: added: mitaka-backport-potential

Reviewed: https://review.openstack.org/311178
Committed: https://git.openstack.org/cgit/openstack/horizon/commit/?id=2e98d7153a09957aae9114a1bbc6ada5fa2be208
Submitter: Jenkins
Branch: master

commit 2e98d7153a09957aae9114a1bbc6ada5fa2be208
Author: Richard Jones <email address hidden>
Date: Fri Apr 29 11:32:15 2016 -0500

    Fix file upload not setting content-type correctly

    The content-type was being set to ", multipart/form-data" because
    the content-type "marker" value was altered from undefined to an empty
    string to appease eslint in this patch:

      https://review.openstack.org/#/c/290738

    Change-Id: I03ebf862bdd86013c974509e1ed851451b81af8a
    Closes-Bug: 1576422

Changed in horizon:
status: In Progress → Fix Released
tags: removed: mitaka-backport-potential

This issue was fixed in the openstack/horizon 10.0.0.0b1 development milestone.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers