latest doa breaks with new db layout

Bug #1499856 reported by Eric Peterson on 2015-09-25
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Critical
Unassigned
django-openstack-auth
Critical
Rob Cresswell
Ubuntu
Undecided
Unassigned

Bug Description

When upgrading to new horizon and doa, a mysql backed session engine sees this error:

ERRORS:
openstack_auth.User.keystone_user_id: (mysql.E001) MySQL does not allow unique CharFields to have a max_length > 255.

Eric Peterson (ericpeterson-l) wrote :

I think this change did it https://review.openstack.org/#/c/222478/

Changed in django-openstack-auth:
importance: Undecided → Critical
Eric Peterson (ericpeterson-l) wrote :

when I try to run the migrate command, the following occurs:

$ tools/with_venv.sh python manage.py migrate
Allowed hosts are: 127.0.0.1,bfd02.os.cloud.twc.net,horizon.os.cloud.twc.net,bfd.os.cloud.twc.net,eric-VirtualBox,127.0.1.1
CommandError: System check identified some issues:

ERRORS:
openstack_auth.User.keystone_user_id: (mysql.E001) MySQL does not allow unique CharFields to have a max_length > 255.

see: https://docs.djangoproject.com/en/1.8/ref/django-admin/#django-admin-migrate

Fix proposed to branch: master
Review: https://review.openstack.org/228024

Changed in django-openstack-auth:
assignee: nobody → Eric Peterson (ericpeterson-l)
status: New → In Progress
Eric Peterson (ericpeterson-l) wrote :

Even with the code changes, there is a larger issue, from running the syncdb / migrate commands from django - as seen in:

http://paste.openstack.org/show/474068/

Eric Peterson (ericpeterson-l) wrote :

I've tested running the syncdb / migrate command, while running older horizon. The older horizon continues to run ok. Then bringing up the new horizon, which now runs the new db layout. Seems to be ok, running through this path.

David Lyle (david-lyle) on 2015-09-29
Changed in horizon:
importance: Undecided → High
importance: High → Critical
tags: added: liberty-rc-potential
tags: added: liberty-rc2-potential
removed: liberty-rc-potential
Changed in horizon:
status: New → Confirmed
Changed in django-openstack-auth:
assignee: Eric Peterson (ericpeterson-l) → David Lyle (david-lyle)
assignee: David Lyle (david-lyle) → Eric Peterson (ericpeterson-l)
assignee: Eric Peterson (ericpeterson-l) → Rob Cresswell (robcresswell)

Reviewed: https://review.openstack.org/228024
Committed: https://git.openstack.org/cgit/openstack/django_openstack_auth/commit/?id=731fc62fb77d1ae1f29a8a8257a19a638e052203
Submitter: Jenkins
Branch: master

commit 731fc62fb77d1ae1f29a8a8257a19a638e052203
Author: eric <email address hidden>
Date: Fri Sep 25 13:59:41 2015 -0600

    doa does not work with mysql

    recent change to specify db user model and it's key
    are not compliant with mysql

    This change modifies the character limit to be 255 instead of 256,
    which is compliant with mysql.

    Change-Id: I85f984c690297003d0e6d696f3103ad5fcf34045
    Closes-bug: #1499856

Changed in django-openstack-auth:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/229994
Committed: https://git.openstack.org/cgit/openstack/django_openstack_auth/commit/?id=88fb89b5b787824d06b4c58337b7c960ccd0263b
Submitter: Jenkins
Branch: stable/liberty

commit 88fb89b5b787824d06b4c58337b7c960ccd0263b
Author: eric <email address hidden>
Date: Fri Sep 25 13:59:41 2015 -0600

    doa does not work with mysql

    recent change to specify db user model and it's key
    are not compliant with mysql

    This change modifies the character limit to be 255 instead of 256,
    which is compliant with mysql.

    Change-Id: I85f984c690297003d0e6d696f3103ad5fcf34045
    Closes-bug: #1499856
    (cherry picked from commit 731fc62fb77d1ae1f29a8a8257a19a638e052203)

tags: added: in-stable-liberty

Change abandoned by Eric Peterson (<email address hidden>) on branch: master
Review: https://review.openstack.org/228536

David Lyle (david-lyle) on 2015-10-07
Changed in horizon:
status: Confirmed → Fix Released
Changed in django-openstack-auth:
status: Fix Committed → Fix Released

Shouldn't the Horizon requirements be updated to include django_openstack_auth>=2.0.1 to ensure that this fix is included?

Paul White (paulw2u) wrote :

Marking the Ubuntu content as "Invalid" to close after 4+ years.

Changed in ubuntu:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers