Incorrect usage of python-novaclient

Bug #1493576 reported by Andrey Kurilin on 2015-09-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cinder
Medium
Ivan Kolodyazhny
Manila
Low
Valeriy Ponomaryov
Mistral
High
Zhenguo Niu
OpenStack DBaaS (Trove)
Undecided
Amrith Kumar
OpenStack Dashboard (Horizon)
High
Timur Sufiev
congress
Undecided
Andrey Kurilin
networking-cisco
Undecided
Andrey Kurilin
os-cloud-config
Undecided
Andrey Kurilin
description: updated
Changed in python-novaclient:
status: New → Invalid
no longer affects: python-novaclient
description: updated
description: updated
tags: added: novaclient
description: updated

Fix proposed to branch: master
Review: https://review.openstack.org/221687

Changed in manila:
assignee: nobody → Valeriy Ponomaryov (vponomaryov)
status: New → In Progress
Changed in manila:
importance: Undecided → Low
Timur Sufiev (tsufiev-x) on 2015-09-09
Changed in horizon:
assignee: nobody → Timur Sufiev (tsufiev-x)

Fix proposed to branch: master
Review: https://review.openstack.org/221711

Changed in horizon:
status: New → In Progress
Ivan Kolodyazhny (e0ne) on 2015-09-09
Changed in cinder:
assignee: nobody → Ivan Kolodyazhny (e0ne)
description: updated

Reviewed: https://review.openstack.org/221711
Committed: https://git.openstack.org/cgit/openstack/horizon/commit/?id=27ceba6035c22b7f11e529ddbc287f27568bb8e8
Submitter: Jenkins
Branch: master

commit 27ceba6035c22b7f11e529ddbc287f27568bb8e8
Author: Timur Sufiev <email address hidden>
Date: Wed Sep 9 14:27:34 2015 +0300

    Fix usage of python-novaclient in Horizon

    Direct `from novaclient.v2 import client` became source of problems
    since the introduction of microversions in Nova. According to
    novaclient docs, `from novaclient import client` (with the following
    specification of version 2 in Client constructor) is a proper way of
    using it. It should safeguard Horizon against the backward
    incompatibility issues, such as in bug 1493205.

    Change-Id: Ifedd47e8ad6a7aac52549f6e1742dd73fed48da1
    Closes-Bug: #1493576
    Closes-Bug: #1493205

Changed in horizon:
status: In Progress → Fix Committed
Changed in manila:
milestone: none → liberty-rc1
Changed in mistral:
assignee: nobody → Zhenguo Niu (niu-zglinux)
description: updated
Changed in mistral:
status: New → In Progress
description: updated

Reviewed: https://review.openstack.org/221687
Committed: https://git.openstack.org/cgit/openstack/manila/commit/?id=e2ce25778492928524aa9b75a7bd0ea6c8f7e472
Submitter: Jenkins
Branch: master

commit e2ce25778492928524aa9b75a7bd0ea6c8f7e472
Author: Valeriy Ponomaryov <email address hidden>
Date: Wed Sep 9 13:16:12 2015 +0300

    Fix usage of novaclient

    We should use 'client interface' for initialization of novaclient
    instead of direct import of some specific client.

    Change-Id: I3172051e4dbba4eb17382cb1393b67829d8c0191
    Closes-Bug: #1493576

Changed in manila:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/221800
Committed: https://git.openstack.org/cgit/openstack/mistral/commit/?id=d5321666a5f9c68be85f49c09f84cc7395fe7e06
Submitter: Jenkins
Branch: master

commit d5321666a5f9c68be85f49c09f84cc7395fe7e06
Author: Zhenguo Niu <email address hidden>
Date: Wed Sep 9 22:27:34 2015 +0800

    Fix usage of python-novaclient in Mistral

    Direct `from novaclient.v2 import client` became source of problems
    since the introduction of microversions in Nova. According to
    novaclient docs, `from novaclient import client` (with the following
    specification of version 2 in Client constructor) is a proper way of
    using it.

    Change-Id: I33879675aced1905ea0c71c22574cce1064e77d4
    Closes-Bug: #1493576

Changed in mistral:
status: In Progress → Fix Committed
Changed in horizon:
importance: Undecided → High
milestone: none → liberty-rc1

Fix proposed to branch: master
Review: https://review.openstack.org/222572

Changed in cinder:
status: New → In Progress
Ivan Kolodyazhny (e0ne) on 2015-09-11
Changed in cinder:
milestone: none → liberty-rc1
importance: Undecided → Medium
Changed in mistral:
status: Fix Committed → Confirmed
Changed in mistral:
status: Confirmed → Fix Committed
milestone: none → liberty-rc1
importance: Undecided → High

Reviewed: https://review.openstack.org/222572
Committed: https://git.openstack.org/cgit/openstack/cinder/commit/?id=c131767a1997d06e8c616e2192d003ef064c4a30
Submitter: Jenkins
Branch: master

commit c131767a1997d06e8c616e2192d003ef064c4a30
Author: Ivan Kolodyazhny <email address hidden>
Date: Fri Sep 11 14:23:02 2015 +0300

    Fix usage of novaclient

    We should use 'client interface' for initialization of novaclient
    instead of direct import of some specific client.

    Change-Id: I51254e20151fe1d6771897e64a8d0bdf2d674d03
    Closes-Bug: #1493576

Changed in cinder:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/223207
Committed: https://git.openstack.org/cgit/openstack/mistral/commit/?id=8c90ee3b7b45ba0dbefb28c298d8c3339226acda
Submitter: Jenkins
Branch: master

commit 8c90ee3b7b45ba0dbefb28c298d8c3339226acda
Author: Christian Berendt <email address hidden>
Date: Mon Sep 14 18:15:15 2015 +0200

    get_action_list: use novaclient.client.Client

    This solves the following issue:

    ---snip---
    UserWarning: 'novaclient.v2.client.Client' is not designed to be
    initialized directly. It is inner class of novaclient. Please, use
    'novaclient.client.Client' instead.
    ---snap---

    Partial-bug: #1493576

    Change-Id: Iceca8ccdfaa15108d3ea321ff164975f5f94ae95

Thierry Carrez (ttx) on 2015-09-22
Changed in manila:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2015-09-24
Changed in cinder:
status: Fix Committed → Fix Released
Changed in mistral:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2015-09-26
Changed in horizon:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2015-10-15
Changed in horizon:
milestone: liberty-rc1 → 8.0.0
Thierry Carrez (ttx) on 2015-10-15
Changed in cinder:
milestone: liberty-rc1 → 7.0.0
Thierry Carrez (ttx) on 2015-10-15
Changed in manila:
milestone: liberty-rc1 → 1.0.0
Changed in mistral:
milestone: liberty-rc1 → liberty
Amrith Kumar (amrith) on 2015-10-17
Changed in trove:
assignee: nobody → Amrith (amrith)
milestone: none → next

Fix proposed to branch: master
Review: https://review.openstack.org/236656

Changed in trove:
status: New → In Progress

Reviewed: https://review.openstack.org/236656
Committed: https://git.openstack.org/cgit/openstack/trove/commit/?id=ccb39eff61abcd17c12915e08eb5ebceb857a186
Submitter: Jenkins
Branch: master

commit ccb39eff61abcd17c12915e08eb5ebceb857a186
Author: Amrith Kumar <email address hidden>
Date: Sat Oct 17 19:27:44 2015 -0400

    Incorrect usage of python-novaclient

    This usage was causing an annoying error message. I've addressed it in
    a configurable way. There's a new config parameter that can be
    changed.

    Change-Id: I78832d0bb2ecdc49901b74d3811764a9676f7c8b
    Closes-Bug: #1493576

Changed in trove:
status: In Progress → Fix Committed

This issue was fixed in the openstack/trove 5.0.0.0b1 development milestone.

Changed in trove:
status: Fix Committed → Fix Released
description: updated
Changed in congress:
assignee: nobody → Andrey Kurilin (andreykurilin)
status: New → In Progress
Changed in networking-cisco:
assignee: nobody → Andrey Kurilin (andreykurilin)
status: New → In Progress
Changed in os-cloud-config:
status: New → In Progress
assignee: nobody → Andrey Kurilin (andreykurilin)

Reviewed: https://review.openstack.org/332423
Committed: https://git.openstack.org/cgit/openstack/networking-cisco/commit/?id=4028533aeda842be6576895e7cc8b48f91137aea
Submitter: Jenkins
Branch: master

commit 4028533aeda842be6576895e7cc8b48f91137aea
Author: Andrey Kurilin <email address hidden>
Date: Tue Jun 21 21:38:59 2016 +0300

    Fix wrong usage of novaclient

    novaclient.client.Client is a documented way to initialize novaclient.
    Also, it provides a backward compatible layer.

    Change-Id: I4f95356835e043fdaeb5f4f5c96139c54eaa32b3
    Closes-Bug: #1493576

Changed in networking-cisco:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/332420
Committed: https://git.openstack.org/cgit/openstack/congress/commit/?id=57411fec5e44c720381d95e1f7c5f83ebf7a5b0d
Submitter: Jenkins
Branch: master

commit 57411fec5e44c720381d95e1f7c5f83ebf7a5b0d
Author: Andrey Kurilin <email address hidden>
Date: Tue Jun 21 21:27:28 2016 +0300

    Fix wrong usage of novaclient

    novaclient.client.Client is a documented way to initialize novaclient.
    Also, it provides a backward compatible layer.

    Change-Id: I9dd15abbeda26c5a6a40139ce47a200720decce8
    Closes-Bug: #1493576

Changed in congress:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/332427
Committed: https://git.openstack.org/cgit/openstack/os-cloud-config/commit/?id=b8603c8d1db01e54faa9bbe9e4d12f8d9d494e3c
Submitter: Jenkins
Branch: master

commit b8603c8d1db01e54faa9bbe9e4d12f8d9d494e3c
Author: Andrey Kurilin <email address hidden>
Date: Tue Jun 21 21:47:31 2016 +0300

    Fix wrong usage of novaclient

    novaclient.client.Client is a documented way to initialize novaclient.
    Also, it provides a backward compatible layer.

    Change-Id: Ibeefe215ff1405d1e6bc478fee415b530813d86c
    Closes-Bug: #1493576

Changed in os-cloud-config:
status: In Progress → Fix Released

This issue was fixed in the openstack/congress 4.0.0.0b2 development milestone.

This issue was fixed in the openstack/os-cloud-config 5.0.0.0b3 development milestone.

This issue was fixed in the openstack/os-cloud-config 5.0.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers