There is no quota check for instance snapshot

Bug #1493122 reported by hossein zabolzadeh on 2015-09-07
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Undecided
Unassigned

Bug Description

There is no quota check for snapshots getting from instances both via APIs and horizon. Imagine a situation in which a normal user can fill-out whole of the cinder(ceph) storage space by calling the get_instance_snapshot() API. But its need to control the amount of instance snapshots by defining instance-snapshot-quota.

How to reproduce?
1- In specific project, launch a new instance.
2- Set the project's quota all the way down(e.g. instances: 1, volume_snapshots: 0, ...).
3- Get snapshots from running instance as much as you can.

You see that there is no quota check and user can fill-out the whole of the storage space.

description: updated
description: updated
tags: added: quota-check
tags: added: horizon-core keystone
removed: quota-check
description: updated
Wang Bo (chestack) wrote :

Refer to: http://docs.openstack.org/user-guide-admin/dashboard_set_quotas.html. There is really no quota for instance snapshots numbers or size.

Other guy had the same confusion: http://www.gossamer-threads.com/lists/openstack/operators/21353

Richard Jones (r1chardj0n3s) wrote :

Closing this bug since there's now a blueprint to track the feature request.

Changed in horizon:
status: New → Invalid
importance: Undecided → Wishlist

Change abandoned by zhaozhilong (<email address hidden>) on branch: master
Review: https://review.openstack.org/281642

Changed in horizon:
assignee: nobody → zhaozhilong (zhaozhilong)
status: Invalid → In Progress
Changed in horizon:
status: In Progress → Invalid
assignee: zhaozhilong (zhaozhilong) → nobody
Changed in horizon:
assignee: nobody → zhaozhilong (zhaozhilong)
status: Invalid → In Progress
Changed in horizon:
assignee: zhaozhilong (zhaozhilong) → nobody
Rajiv Mucheli (rajiv.mucheli) wrote :

Hi,

Is this fixed? or is there a workaround ?

Brian Rosmaita (brian-rosmaita) wrote :

Configure user_storage_quota in glance-api.conf

Akihiro Motoki (amotoki) wrote :

This bug is reported to horizon. As horizon, glance does not provide any quota information via API, so there is nothing that horizon can do.

The only way is to configure quota in glance configuration file (as Brian mentioned in the previous comment).

Based on the above, this is not a horizon bug and I am marking this as Invalid.

Changed in horizon:
status: In Progress → Invalid
importance: Wishlist → Undecided
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers