I18n: the downloaded CVS summary is in mixed languages

Bug #1226910 reported by Ying Chun Guo on 2013-09-18
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Medium
Jeffrey Zhang
Havana
Medium
Akihiro Motoki

Bug Description

Hi,

When I set the language in Chinese, and downloaded the CVS summary from the "Overview" page, I found the CVS file were in two langauges. The start date and end date of a period were described in Chinese. "Project ID" was translated in Chinese. Others were still in English.

----Here is an example----
Usage Report For Period:,九月. 17 2013,九月. 17 2013
项目ID:,d2c23998b9364d7d8c5242536f117e1f
Total Active VCPUs:,0
CPU-HRs Used:,0.00
Total Active Ram (MB):,0
Total Disk Size:,0
Total Disk Usage:,0.00
Instance Name,VCPUs,Ram (MB),Disk (GB),Usage (Hours),Uptime(Seconds),State

Regards
Daisy

description: updated
Changed in horizon:
importance: Undecided → Medium
milestone: none → icehouse-1
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/51597

Changed in horizon:
assignee: nobody → Jeffrey Zhang (jeffrey4l)
status: Confirmed → In Progress
Akihiro Motoki (amotoki) wrote :

From the discussion in the review, the cause is the default target files of Django manage.py makemessages are *.html and *.py, and CSV files are not processed. The proposed patch is now updating run_tests.sh to add *.csv to the target files.

Reviewed: https://review.openstack.org/51597
Committed: http://github.com/openstack/horizon/commit/0b03a7fdea3d6586ec2c22783e309bb75d68fdc5
Submitter: Jenkins
Branch: master

commit 0b03a7fdea3d6586ec2c22783e309bb75d68fdc5
Author: Lei Zhang <email address hidden>
Date: Mon Oct 14 22:00:34 2013 +0800

    Add extra extension file to makemessage command line

    specify the file extensions of the makemessage to *.html, *.txt, *.csv

    Closes-Bug: #1226910
    Change-Id: I115cd448249ac0b1b27a6b28fca3f16d6b2670a6

Changed in horizon:
status: In Progress → Fix Committed
Julie Pichon (jpichon) wrote :

Should this updated command be backported (+ extra fix in commit 79ae2139bb) to Havana in order for us to generate more complete .po files before the next stable update, or do we want to avoid adding new strings to the Havana po files?

It seems to me - backporting to Havana wouldn't hurt since the strings are not translated now anyway. Translators who have the time and will to translate these new strings would then be free to do it if they so wish.

Ying Chun Guo (daisy-ycguo) wrote :

I prefer to backport.
There won't be many strings.

Julie Pichon (jpichon) on 2013-11-26
tags: added: havana-backport-potential
Akihiro Motoki (amotoki) wrote :

Agree to havana backport.

Akihiro Motoki (amotoki) on 2013-12-04
tags: removed: havana-backport-potential
Thierry Carrez (ttx) on 2013-12-04
Changed in horizon:
status: Fix Committed → Fix Released

Reviewed: https://review.openstack.org/59916
Committed: http://github.com/openstack/horizon/commit/06e78a8bd7c7d3d777c152230f9b8c88d2dd0487
Submitter: Jenkins
Branch: stable/havana

commit 06e78a8bd7c7d3d777c152230f9b8c88d2dd0487
Author: Akihiro Motoki <email address hidden>
Date: Tue Dec 3 23:56:48 2013 +0900

    Add extra extension file to makemessage command line

    specify the file extensions of the makemessage to *.html, *.txt, *.csv

    Closes-Bug: #1226910
    (cherry picked from commit 0b03a7fdea3d6586ec2c22783e309bb75d68fdc5)

    The above fix introduces an extra bug when updating POT files, so
    the commit below is also cherry-picked.
    ----
    Fix warning in run_tests.sh --makemessages

    Specify --extension=html,txt,csv only for openstack_dashboard.
    For djangojs, --extension should be 'js'.
    This is the cause of the warning.

    Closes-Bug: #1243526
    (cherry picked from commit 79ae2139bb2f458de698aa116270428f54e22dc6)
    ----

    This patch does not update POT files for stable/havana.
    They will be updated in a single patch.

    Change-Id: I115cd448249ac0b1b27a6b28fca3f16d6b2670a6

Thierry Carrez (ttx) on 2014-04-17
Changed in horizon:
milestone: icehouse-1 → 2014.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers