rename requires files to standard names

Bug #1179008 reported by Monty Taylor on 2013-05-11
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ceilometer
Fix Released
Undecided
Angus Salkeld
Cinder
Wishlist
Zhenguo Niu
Gear
New
Undecided
Unassigned
Glance
Undecided
Unassigned
Glance Client
Undecided
Zhenguo Niu
OpenStack Compute (nova)
Undecided
Ruby Loo
OpenStack DBaaS (Trove)
Medium
Nikhil Manchanda
OpenStack Dashboard (Horizon)
Wishlist
Jiri Tomasek
OpenStack Heat
Fix Released
Low
Steven Dake
OpenStack Identity (keystone)
Wishlist
Carlos Garza
OpenStack Object Storage (swift)
Undecided
Zhenguo Niu
Python client library for Zaqar
Undecided
Alexej Ababilov
Zuul
In Progress
Undecided
Unassigned
git-review
Fix Committed
Medium
Unassigned
neutron
Medium
Zhenguo Niu
oslo-incubator
Low
Zhenguo Niu
python-ceilometerclient
Undecided
Angus Salkeld
python-cinderclient
Wishlist
Monty Taylor
python-keystoneclient
Low
Carlos Garza
python-neutronclient
Medium
Carlos Garza
python-novaclient
Low
Monty Taylor
python-openstackclient
Fix Released
Low
Zhenguo Niu
python-swiftclient
Undecided
Zhenguo Niu

Bug Description

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Rename tools/pip-requires to requirements.txt and tools/test-requires
to test-requirements.txt. These are standard files and tools in the
general world are growing intelligence about them.

 affects ceilometer
 affects cinder
 affects git-review
 affects glance
 affects heat-cfntools
 affects heat
 affects horizon
 affects keystone
 affects nova
 affects openstack-ci
 affects oslo
 affects python-ceilometerclient
 affects python-cinderclient
 affects python-gear
 affects python-glanceclient
 affects python-heatclient
 affects python-keystoneclient
 affects python-novaclient
 affects python-openstackclient
 affects python-quantumclient
 affects python-swiftclient
 affects quantum
 affects reddwarf
 affects swift
 affects tempest
 affects zuul
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)
Comment: Using GnuPG with undefined - http://www.enigmail.net/

iEYEARECAAYFAlGObegACgkQ2Jv7/VK1RgH+yQCbBuxIZvk/Ra4TEK0TlLqr3xAU
cj8An1NPMiQ47VubNdsKg6ybymtRRjto
=fwhb
-----END PGP SIGNATURE-----

Changed in horizon:
importance: Undecided → Wishlist
milestone: none → havana-1
status: New → Confirmed
Changed in nova:
assignee: nobody → Sushanta Mishra (mishra-sushantakumar)
status: New → In Progress
Steven Dake (sdake) on 2013-05-16
Changed in heat-cfntools:
assignee: nobody → Steven Dake (sdake)
status: New → In Progress
importance: Undecided → Wishlist

Fix proposed to branch: master
Review: https://review.openstack.org/29339

Changed in python-heatclient:
assignee: nobody → Steven Dake (sdake)
status: New → In Progress
Steven Dake (sdake) on 2013-05-16
Changed in heat:
assignee: nobody → Steven Dake (sdake)
importance: Undecided → Low
status: New → In Progress
Steven Dake (sdake) on 2013-05-16
Changed in heat:
milestone: none → havana-1
Changed in heat-cfntools:
importance: Wishlist → Low
Changed in python-heatclient:
importance: Undecided → Low
milestone: none → v0.2.3
Angus Salkeld (asalkeld) on 2013-05-17
Changed in ceilometer:
assignee: nobody → Angus Salkeld (asalkeld)
status: New → Confirmed
Changed in python-ceilometerclient:
assignee: nobody → Angus Salkeld (asalkeld)
status: New → Confirmed
Clint Byrum (clint-fewbar) wrote :

Before these land in trunk for all services we need tripleo to support requirements.txt

https://review.openstack.org/#/c/29626/

Changed in tripleo:
importance: Undecided → Critical
status: New → Triaged

Fix proposed to branch: master
Review: https://review.openstack.org/29657

Changed in python-cinderclient:
assignee: nobody → Monty Taylor (mordred)
status: New → In Progress
Changed in python-novaclient:
assignee: nobody → Monty Taylor (mordred)
status: New → In Progress
no longer affects: tripleo
Changed in quantum:
assignee: nobody → Mark McClain (markmcclain)
importance: Undecided → High
milestone: none → havana-1
status: New → Confirmed
importance: High → Medium
Changed in python-quantumclient:
importance: Undecided → Medium
milestone: none → 3.0.0
status: New → Confirmed

Reviewed: https://review.openstack.org/29401
Committed: http://github.com/openstack/heat-cfntools/commit/8b813462b7e1573dd841e8f6d9d0d688321dc23d
Submitter: Jenkins
Branch: master

commit 8b813462b7e1573dd841e8f6d9d0d688321dc23d
Author: Steven Dake <email address hidden>
Date: Thu May 16 09:31:51 2013 -0700

    Rename requires files to standard names

    From bug report:
    Rename tools/pip-requires to requirements.txt and tools/test-requires
    to test-requirements.txt. These are standard files and tools in the
    general world are growing intelligence about them.

    Change-Id: I5d3bad7654e4ce101d19b40215d8c1cc93dd9832
    Fixes: Bug #1179008

Changed in heat-cfntools:
status: In Progress → Fix Committed

Fix proposed to branch: master
Review: https://review.openstack.org/29876

Changed in python-ceilometerclient:
status: Confirmed → In Progress
Changed in nova:
status: In Progress → New
assignee: Sushanta Mishra (mishra-sushantakumar) → nobody
Changed in horizon:
milestone: havana-1 → havana-2

Reviewed: https://review.openstack.org/29657
Committed: http://github.com/openstack/python-cinderclient/commit/c82a811301d78ecdabf7786e0c5cee10879db87f
Submitter: Jenkins
Branch: master

commit c82a811301d78ecdabf7786e0c5cee10879db87f
Author: Monty Taylor <email address hidden>
Date: Sat May 18 09:18:07 2013 -0700

    Rename requires files to standard names.

    Fixes bug 1179008.

    Change-Id: I6765bb82df1ae672790662a30ee3527450685036

Changed in python-cinderclient:
status: In Progress → Fix Committed
Michael Still (mikal) on 2013-05-22
Changed in oslo:
importance: Undecided → Low
status: New → Triaged
Changed in python-novaclient:
importance: Undecided → Low
Ruby Loo (rloo) on 2013-05-22
Changed in nova:
assignee: nobody → Ruby Loo (rloo)
status: New → In Progress

Reviewed: https://review.openstack.org/29876
Committed: http://github.com/openstack/python-ceilometerclient/commit/f987463cae866439d7bd1a09190c2a4afa585695
Submitter: Jenkins
Branch: master

commit f987463cae866439d7bd1a09190c2a4afa585695
Author: Angus Salkeld <email address hidden>
Date: Tue May 21 20:29:19 2013 +1000

    Rename tools/pip-requires to requirements.txt

    (and tools/test-requires to test-requirements.txt).

    Requested by infra: bug 1179008

    Change-Id: I7a6375622d095a9eda232ed82d167fc3a198ed06

Changed in python-ceilometerclient:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/30161
Committed: http://github.com/openstack/nova/commit/5740920bb392ec6e0bc5f2e3949a37b3bf8519d9
Submitter: Jenkins
Branch: master

commit 5740920bb392ec6e0bc5f2e3949a37b3bf8519d9
Author: Ruby Loo <email address hidden>
Date: Wed May 22 20:12:08 2013 +0000

    Rename requires files to standard names.

    Rename tools/pip-requires to requirements.txt and tools/test-requires
    to test-requirements.txt. These are standard files, and tools in the
    general world are growing intelligence about them.

    Change-Id: I68ece8406fb1d4e082a42db8e76e17b1aaa7e775
    Fixes: bug #1179008

Changed in nova:
status: In Progress → Fix Committed
Changed in keystone:
assignee: nobody → Carlos Garza (carlos-garza)
status: New → Confirmed
Changed in python-keystoneclient:
assignee: nobody → Carlos Garza (carlos-garza)
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/30507

Changed in keystone:
status: Confirmed → In Progress
Changed in python-quantumclient:
assignee: nobody → Carlos Garza (carlos-garza)
status: Confirmed → In Progress
Changed in python-keystoneclient:
status: Confirmed → In Progress
Changed in python-quantumclient:
status: In Progress → Fix Committed
Changed in keystone:
status: In Progress → Fix Committed
Changed in python-keystoneclient:
status: In Progress → Fix Committed
Thierry Carrez (ttx) wrote :

Do not set to FixCommitted until it's merged.

Changed in python-quantumclient:
status: Fix Committed → In Progress
Changed in keystone:
status: Fix Committed → In Progress
Changed in python-keystoneclient:
status: Fix Committed → In Progress
Download full text (3.2 KiB)

Sorry the word commit was throwing me off.

Sent from my iPhone

On May 27, 2013, at 4:51 AM, "Thierry Carrez" <email address hidden> wrote:

> Do not set to FixCommitted until it's merged.
>
> ** Changed in: python-quantumclient
> Status: Fix Committed => In Progress
>
> ** Changed in: keystone
> Status: Fix Committed => In Progress
>
> ** Changed in: python-keystoneclient
> Status: Fix Committed => In Progress
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1179008
>
> Title:
> rename requires files to standard names
>
> Status in Ceilometer:
> Confirmed
> Status in Cinder:
> New
> Status in Git Review:
> New
> Status in OpenStack Image Registry and Delivery Service (Glance):
> New
> Status in Orchestration API (Heat):
> In Progress
> Status in Heat API Instance Tools:
> Fix Committed
> Status in OpenStack Dashboard (Horizon):
> Confirmed
> Status in OpenStack Identity (Keystone):
> In Progress
> Status in OpenStack Compute (Nova):
> Fix Committed
> Status in OpenStack Core Infrastructure:
> New
> Status in Oslo - a Library of Common OpenStack Code:
> Triaged
> Status in Ceilometer Python Client:
> Fix Committed
> Status in Python client library for Cinder:
> Fix Committed
> Status in Python Gearman Interface:
> New
> Status in Python client library for Glance:
> New
> Status in Heat python client:
> In Progress
> Status in Python client library for Keystone:
> In Progress
> Status in Python client library for Nova:
> In Progress
> Status in OpenStack Command Line Client:
> New
> Status in Python client library for Quantum:
> In Progress
> Status in Python client library for Swift:
> New
> Status in OpenStack Quantum (virtual network service):
> Confirmed
> Status in RedDwarf - Database as a Service:
> New
> Status in OpenStack Object Storage (Swift):
> New
> Status in Tempest:
> New
> Status in Zuul: A project gating system:
> New
>
> Bug description:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Rename tools/pip-requires to requirements.txt and tools/test-requires
> to test-requirements.txt. These are standard files and tools in the
> general world are growing intelligence about them.
>
> affects ceilometer
> affects cinder
> affects git-review
> affects glance
> affects heat-cfntools
> affects heat
> affects horizon
> affects keystone
> affects nova
> affects openstack-ci
> affects oslo
> affects python-ceilometerclient
> affects python-cinderclient
> affects python-gear
> affects python-glanceclient
> affects python-heatclient
> affects python-keystoneclient
> affects python-novaclient
> affects python-openstackclient
> affects python-quantumclient
> affects python-swiftclient
> affects quantum
> affects reddwarf
> affects swift
> affects tempest
> affects zuul
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.12 (GNU/Linux)
> Comment: Using GnuPG with undefined - http://www.enigmail.net/
>
> iEYEARECAAYFAlGObegACgkQ2Jv7/VK1RgH+yQCbBuxIZvk/Ra4TEK0TlLqr3xAU
> cj8An1NPMiQ47VubNdsKg6ybymtRRjto
> =fwhb
> -----END PGP SIGNATURE-----
>
> To man...

Read more...

Fix proposed to branch: master
Review: https://review.openstack.org/30649

Changed in ceilometer:
status: Confirmed → In Progress
Jiri Tomasek (jtomasek) on 2013-05-28
Changed in horizon:
assignee: nobody → Jiri Tomasek (jtomasek)

Reviewed: https://review.openstack.org/30649
Committed: http://github.com/openstack/ceilometer/commit/2fcd26397a7f2b328c7e4ff6f244ca3c818afe99
Submitter: Jenkins
Branch: master

commit 2fcd26397a7f2b328c7e4ff6f244ca3c818afe99
Author: Angus Salkeld <email address hidden>
Date: Tue May 28 10:11:07 2013 +1000

    Rename requires files to standard names

    requested by infra.

    bug 1179008

    Change-Id: Id27f574a023792c287ed4e11aa869cb50857aa8f

Changed in ceilometer:
status: In Progress → Fix Committed
Steven Hardy (shardy) on 2013-05-28
Changed in heat:
status: In Progress → Fix Committed
Changed in quantum:
milestone: havana-1 → havana-2

Reviewed: https://review.openstack.org/29649
Committed: http://github.com/openstack/python-novaclient/commit/3bbdcda9d23b54079733ff6f06000cf311eff629
Submitter: Jenkins
Branch: master

commit 3bbdcda9d23b54079733ff6f06000cf311eff629
Author: Monty Taylor <email address hidden>
Date: Sat May 18 07:17:04 2013 -0700

    Rename requires files to standard names.

    The python community groks requirements.txt and test-requirements.txt as
    reasonably standard files. We should use those filenames to make our
    information more discoverable.

    Fixes bug 1179008

    Change-Id: I50a7c46f880e4257fa31d7d322d7bf70b0f5d3a6

Changed in python-novaclient:
status: In Progress → Fix Committed
Changed in horizon:
assignee: Jiri Tomasek (jtomasek) → 牛振国 (niu-zglinux)
Changed in python-glanceclient:
assignee: nobody → 牛振国 (niu-zglinux)
Changed in cinder:
assignee: nobody → 牛振国 (niu-zglinux)
Changed in glance:
assignee: nobody → 牛振国 (niu-zglinux)

Fix proposed to branch: master
Review: https://review.openstack.org/30845

Changed in horizon:
status: Confirmed → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/30846

Changed in cinder:
status: New → In Progress
Thierry Carrez (ttx) on 2013-05-29
Changed in ceilometer:
milestone: none → havana-1
status: Fix Committed → Fix Released
Changed in heat:
status: Fix Committed → Fix Released

Fix proposed to branch: master
Review: https://review.openstack.org/30848

Changed in glance:
status: New → In Progress
Changed in horizon:
assignee: 牛振国 (niu-zglinux) → nobody

Fix proposed to branch: master
Review: https://review.openstack.org/30851

Changed in python-glanceclient:
status: New → In Progress
Changed in python-openstackclient:
assignee: nobody → 牛振国 (niu-zglinux)

Fix proposed to branch: master
Review: https://review.openstack.org/30853

Changed in python-openstackclient:
status: New → In Progress
Changed in tempest:
assignee: nobody → 牛振国 (niu-zglinux)
Changed in python-swiftclient:
assignee: nobody → 牛振国 (niu-zglinux)

Fix proposed to branch: master
Review: https://review.openstack.org/30855

Changed in tempest:
status: New → In Progress
Jiri Tomasek (jtomasek) on 2013-05-29
Changed in horizon:
assignee: nobody → Jiri Tomasek (jtomasek)
Changed in swift:
assignee: nobody → 牛振国 (niu-zglinux)
Thierry Carrez (ttx) on 2013-05-29
Changed in nova:
milestone: none → havana-1
status: Fix Committed → Fix Released

Reviewed: https://review.openstack.org/30679
Committed: http://github.com/openstack/horizon/commit/5b24518b10a842dcceb4236860ac3e80839f1789
Submitter: Jenkins
Branch: master

commit 5b24518b10a842dcceb4236860ac3e80839f1789
Author: Jiri Tomasek <email address hidden>
Date: Tue May 28 10:06:10 2013 +0200

    Renames tools/pip-requires to requirements.txt

    and tools/test-requires to test-requirements.txt

    These are standard files and tools in the
    general world are growing intelligence about them.

    Change-Id: Iac3c680dd19cabd8ea38598a6e2bb27238030a2d
    Fixes: bug #1179008

Changed in horizon:
status: In Progress → Fix Committed
Changed in python-gear:
assignee: nobody → 牛振国 (niu-zglinux)
Changed in openstack-ci:
assignee: nobody → 牛振国 (niu-zglinux)

Fix proposed to branch: master
Review: https://review.openstack.org/30887

Changed in swift:
status: New → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/30889

Changed in python-swiftclient:
status: New → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/30893

Changed in zuul:
assignee: nobody → 牛振国 (niu-zglinux)
status: New → In Progress

Reviewed: https://review.openstack.org/30853
Committed: http://github.com/openstack/python-openstackclient/commit/bac0718764ac5e7cc22adf24d035db0be0cf90d9
Submitter: Jenkins
Branch: master

commit bac0718764ac5e7cc22adf24d035db0be0cf90d9
Author: Zhenguo Niu <email address hidden>
Date: Wed May 29 17:36:23 2013 +0800

    Rename requires files to standard names.

    Rename tools/pip-requires to requirements.txt and tools/test-requires
    to test-requirements.txt. These are standard files, and tools in the
    general world are growing intelligence about them.

    Change-Id: I903213fda94a833335abaa7ad9a90bbb688ec15a
    Fixes: bug #1179008

Changed in python-openstackclient:
status: In Progress → Fix Committed
Dolph Mathews (dolph) on 2013-05-29
Changed in python-keystoneclient:
importance: Undecided → Low
Dolph Mathews (dolph) wrote :
Changed in python-keystoneclient:
milestone: none → 0.2.4
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
Changed in python-gear:
assignee: 牛振国 (niu-zglinux) → nobody
Changed in openstack-ci:
assignee: 牛振国 (niu-zglinux) → nobody

Fix proposed to branch: master
Review: https://review.openstack.org/30995

Changed in oslo:
assignee: nobody → 牛振国 (niu-zglinux)
status: Triaged → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/30997

Changed in quantum:
assignee: Mark McClain (markmcclain) → 牛振国 (niu-zglinux)
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/30507
Committed: http://github.com/openstack/keystone/commit/2bc22ef6f7e21701188eb97376d15c8f57a56881
Submitter: Jenkins
Branch: master

commit 2bc22ef6f7e21701188eb97376d15c8f57a56881
Author: Carlos D. Garza <email address hidden>
Date: Fri May 24 17:51:31 2013 -0500

       Rename requires files to standard names.

        Rename tools/pip-requires to requirements.txt and tools/test-requires
        to test-requirements.txt. These are standard files, and tools in the
        general world are growing intelligence about them.

    Fixes: bug #1179008
    Change-Id: I1a19f0c73ab48987e2ff0dade1a57a68b65f0a22

Changed in keystone:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/30997
Committed: http://github.com/openstack/quantum/commit/47846a7a6320b424a50571e4d35595644d9ce133
Submitter: Jenkins
Branch: master

commit 47846a7a6320b424a50571e4d35595644d9ce133
Author: Zhenguo Niu <email address hidden>
Date: Thu May 30 13:36:22 2013 +0800

    Rename requires files to standard names.

    Rename tools/pip-requires to requirements.txt and tools/test-requires
    to test-requirements.txt. These are standard files, and tools in the
    general world are growing intelligence about them.

    Fixes: bug #1179008
    Change-Id: I6f8a11988982133249d443403f63b4f8724e156e

Changed in quantum:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/30846
Committed: http://github.com/openstack/cinder/commit/15a907c491e9d344fd1f70becc883342f3102798
Submitter: Jenkins
Branch: master

commit 15a907c491e9d344fd1f70becc883342f3102798
Author: Zhenguo Niu <email address hidden>
Date: Wed May 29 16:50:03 2013 +0800

    Rename requires files to standard names.

    Rename tools/pip-requires to requirements.txt and tools/test-requires
    to test-requirements.txt. These are standard files, and tools in the
    general world are growing intelligence about them.

    Change-Id: Ifb2735151dc8c7f89ec01d237226669f7051ffa8
    Fixes: bug #1179008

Changed in cinder:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/30889
Committed: http://github.com/openstack/python-swiftclient/commit/2d12f09c66e0221ba7f43cc64677c05486a42ea6
Submitter: Jenkins
Branch: master

commit 2d12f09c66e0221ba7f43cc64677c05486a42ea6
Author: niu-zglinux <email address hidden>
Date: Wed May 29 22:13:02 2013 +0800

    Rename requires files to standard names.

    Rename tools/pip-requires to requirements.txt and tools/test-requires
    to test-requirements.txt. These are standard files, and tools in the
    general world are growing intelligence about them.

    Change-Id: I9c1356f22f6527be44b4b3f6a77012156ff1637b
    Fixes: bug #1179008

Changed in python-swiftclient:
status: In Progress → Fix Committed
Changed in cinder:
milestone: none → havana-2
importance: Undecided → Wishlist
Changed in python-cinderclient:
importance: Undecided → Wishlist

Reviewed: https://review.openstack.org/30851
Committed: http://github.com/openstack/python-glanceclient/commit/40460cbeb1f0b08b82fdf405b3341eebf5612cb0
Submitter: Jenkins
Branch: master

commit 40460cbeb1f0b08b82fdf405b3341eebf5612cb0
Author: Zhenguo Niu <email address hidden>
Date: Wed May 29 17:23:30 2013 +0800

    Rename requires files to standard names.

    Rename tools/pip-requires to requirements.txt and tools/test-requires
    to test-requirements.txt. These are standard files, and tools in the
    general world are growing intelligence about them.

    Change-Id: Ic220b54de5ce7c15f442b8ffcb97cd03c2344f9a
    Fixes: bug #1179008

Changed in python-glanceclient:
status: In Progress → Fix Committed
Changed in swift:
status: In Progress → Fix Committed
Changed in tempest:
status: In Progress → Fix Committed
James E. Blair (corvus) on 2013-06-04
Changed in openstack-ci:
assignee: nobody → Monty Taylor (mordred)
importance: Undecided → Medium
milestone: none → havana
status: New → In Progress

Reviewed: https://review.openstack.org/30995
Committed: http://github.com/openstack/oslo-incubator/commit/70747145f9cd8e19280ea9958f6fccc8f95fbe44
Submitter: Jenkins
Branch: master

commit 70747145f9cd8e19280ea9958f6fccc8f95fbe44
Author: Zhenguo Niu <email address hidden>
Date: Thu May 30 10:40:43 2013 +0800

    Rename requires files to standard names.

    Rename tools/pip-requires to requirements.txt and tools/test-requires
    to test-requirements.txt. These are standard files, and tools in the
    general world are growing intelligence about them.

    Fixes: bug #1179008
    Change-Id: I033876ec304fea97c66365c16bcf0cccaa1d810e

Changed in oslo:
status: In Progress → Fix Committed
Dolph Mathews (dolph) on 2013-06-10
Changed in keystone:
importance: Undecided → Wishlist
Changed in reddwarf:
assignee: nobody → Nikhil Manchanda (slicknik)
Changed in python-reddwarfclient:
assignee: nobody → Nikhil Manchanda (slicknik)
Changed in python-marconiclient:
assignee: nobody → Alessio Ababilov (aababilov)

Fix proposed to branch: master
Review: https://review.openstack.org/33064

Changed in python-marconiclient:
status: New → In Progress
Changed in swift:
milestone: none → 1.9.0
Nikhil Manchanda (slicknik) wrote :

Mordred seems to have fixed this as part of the troveclient pbr changes.
Thanks!

Changed in trove:
milestone: none → havana-2
Changed in python-troveclient:
milestone: none → havana-2
status: New → Fix Committed
Nikhil Manchanda (slicknik) wrote :

Mordred seems to have fixed this as part of the trove pbr changes.
Thanks!

Changed in trove:
status: New → Fix Committed
Changed in zuul:
assignee: 牛振国 (niu-zglinux) → nobody
Thierry Carrez (ttx) on 2013-06-26
Changed in swift:
status: Fix Committed → Fix Released

I am out of the office until 07/01/2013.

I will be on vacation until Monday, July 1st and will not be able to
respond to emails for the majority of my time away. Please contact Johanna
Koester, my manager, in case of emergencies.

Note: This is an automated response to your message "[Bug 1179008] Re:
rename requires files to standard names" sent on 06/26/2013 4:22:00 AM.

This is the only notification you will receive while this person is away.

Changed in heat-cfntools:
milestone: none → v1.2.4
Changed in python-troveclient:
importance: Undecided → Medium
Changed in trove:
importance: Undecided → Medium
Clint Byrum (clint-fewbar) wrote :

commit 37684327070859c3d4a8ed47b43f18b9858bd436
Author: Monty Taylor <email address hidden>
Date: Sat May 25 08:41:07 2013 +0200

    Move requirements files to standard names.

    Change-Id: Ia27def1cf04aae8fe6e9f19e965b0083638d2201

Changed in python-heatclient:
status: In Progress → Fix Committed

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

 affects cinder
 status fixreleased
 affects keystone
 status fixreleased
 milestone havana-2
 affects horizon
 status fixreleased
 affects trove
 status fixreleased
 affects neutron
 status fixreleased
 affects oslo
 status fixreleased
 milestone havana-2
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)
Comment: Using GnuPG with undefined - http://www.enigmail.net/

iQIcBAEBCAAGBQJR5q4UAAoJEFB6+JAlsQQjuFUQAJJ6Q/ie6qXcl+52FiVI/tVg
V9hiFaFRrwUsbFsCtZU8AlR1aJmWPVyjuOeTOa6VczAxZh1f68HsQYP3EDYp1YhF
iJ5rwcaRlGIAPMiaPkLfjZu+okkyV73w/2maANDFK0QOhI7sOAKp2ILjBhJoZGlF
v5SN+5JG27Brtv9JR9rJ3G7Qml4v6baQaaUUkdlOnWf34tnD9vreJhdNb2Q0K180
KpDJeSd49vD/1RsMRXfvc7Xuh8KfaJJmwaowdMRVXPghVKfNRkNFNo82o7AaS8OK
aM0QIA6jZzFdXwzp9HUG66OYRM3G1dcn5gNDuXM1K17FEs7yF+j+FWoP2GG9q7kQ
B3glGsV4gfJV7+NHi6WP9EUG5sHinXHWTMLGWZ3j7CD31dTQNSJOdtVCaPcEBrGt
IY6Gpe3R8FfnxAMeWDkroYrn/ZZpHeVaz7SyKrsOB+heS6oWoG+bSYyK33s7NWxt
Ox8ZA71rwmIDrBYnxWFVLnNn77Buc1/ekto/7YwtF7/mikoHHKhI9im/1Z5pszz7
e/2FsbvP0CJ5ILP0hbvwXvzjGCFHMo7lt63xlXqhx4i1rPnWTOq9nvg0OypJDEnm
dD/+2KoDZiCkgBXjxKrLoT2x1bnWgCWIeYpYio5Jo9CvCcZghB0bnyW1m7dLch0p
TBqBCwE6ngs487rGrpDl
=ZTL3
-----END PGP SIGNATURE-----

Changed in cinder:
status: Fix Committed → Fix Released
Changed in horizon:
status: Fix Committed → Fix Released
Changed in keystone:
milestone: none → havana-2
status: Fix Committed → Fix Released
Changed in neutron:
status: Fix Committed → Fix Released
Changed in oslo:
milestone: none → havana-2
status: Fix Committed → Fix Released
Changed in trove:
status: Fix Committed → Fix Released
Changed in glance:
assignee: Zhenguo Niu (niu-zglinux) → nobody
status: In Progress → Fix Committed

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

 affects glance
 status fixreleased
 milestone havana-3
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)
Comment: Using GnuPG with undefined - http://www.enigmail.net/

iQIcBAEBCAAGBQJSKG18AAoJEFB6+JAlsQQjWeYP/0C+CU94rns3wLharz+XJ8pg
+zKnMJu7c1twbUdyWJY16ukXe3rrDyf88gvJb9eK+IPDQyG7cbY3PVY7UL8sRUwV
TegDBFkB+WxgihL7WrPWWRY+1t9WIDNquq6xsvlT+4o2LUUD0kRJv2qs4jnxEP66
Ek4hYEOVsbTSXnZWcxmQ7Kv0XM4Zs6HQwju2ZxV1FRUC4Gly/NJ/L5PPa2ythzTc
Hf3OfbFOpYPpkQQ2CCq66GHNvCv4iKIAbv04dFDaqDK3Ex2LF7JQuUEstXADfffS
S9AuBdkFA0rUMkPEfrxpC77Wvo8XkqVvoG52ux1vWGaOD7+DTo5ArXwfJBBXQrTF
Ulh8qC/8XzJHXHO8YVGgER+0UmVB76lemyrxzLlbTP+yhL/lN/Unpjv81ehuD+3D
mkwEwLJladZF+TPz3jw1gkwpE8h7O5EZMTfCXMCJ9Bbko5twZxmEmx2/Gp+lD95e
F2ZnEu73uTFTvtEp1/YCmNiHA7Uc8xCMJwiVqkhxYsnaXGDe3iKj1UuuQ8PGuCdU
uN/D9Nk/ZoySb8wdroEOr8lRddMWQOH7ZiaOkSBdOK0iadAKZ/w9oCfRuzL/CbBz
arf7+DXHGWUWKKxbGkn3rYQpUjGsAvxnSFER2ITHTx1FX98gMj8uL6GPJorqE8kI
Yasy7SdTR2Z5ZLjIXEpb
=3VGL
-----END PGP SIGNATURE-----

Changed in glance:
milestone: none → havana-3
status: Fix Committed → Fix Released

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

 affects ceilometer
 milestone 2013.2
 affects cinder
 milestone 2013.2
 affects glance
 milestone 2013.2
 affects keystone
 milestone 2013.2
 affects nova
 milestone 2013.2
 affects horizon
 milestone 2013.2
 affects trove
 milestone 2013.2
 affects heat
 milestone 2013.2
 affects neutron
 milestone 2013.2
 affects oslo
 milestone 2013.2
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQIcBAEBCAAGBQJSX6qhAAoJEFB6+JAlsQQj7lQP/AtA/xVCQ1qRVduaqMKGqmeo
an6zbBZl0MePbQPkLoq2Vqc1mzOBx5/6Yvx2jxymtX3QHYl87qUC8fSWwT+Dbk9K
Je6Dst745wMN5seIsDN6Ee27JGC6HuNW7CJc9EYUoAqhGJBJ1mQwFGxrRrgx1lWO
n35QdogKD7rwLqv1h6CmJdZBdvyUbMQ8CG9a3lRZi/PSCddSyyV5QLZeX3g53GCN
+jrargktyOGT7riTL4rSdTV6xM03N09sVzckUX5OuFbUGZciIRa91+MSHc+DpG30
wdErVGeS28vlLXgAKQe95BkoRLu31V4XhCO8jvS2AyeAjvuW/s+2lwZjjmPK3H9+
+C44WkiMJhpo8gVzOjJPqbHQ0eEX0hAGR6KX9RB8estPBWtZPGQOS9eVrdxkvJai
oqnf+Q4CToXLsbpxUrJA6frGcMqV0YA7liSq79u4ePs6sblKSQ3He7ngBaBjTuwL
vt88WIVFZt1z8IBst+jYbYTfd5oGnd0DdOoe/qBTt6F3D919sBhBsXm3ki9ZrpeO
5Q3xlOUNPE9xx5joH/3AGrwWoBCFwsbzWwizUkqp3Ih4C+aGAe0NbR52vMA9Jo7o
xNAHJWjRIqtdSkNbSu9jv/+qXFxmEaFNZJX+LFU2pM9/MX9Lx+7ikJw2Y7uIgCpM
9HwwMlEcH2Di5ijHnx9h
=UICv
-----END PGP SIGNATURE-----

Changed in ceilometer:
milestone: havana-1 → 2013.2
Changed in cinder:
milestone: havana-2 → 2013.2
Changed in glance:
milestone: havana-3 → 2013.2
Changed in heat:
milestone: havana-1 → 2013.2
Changed in horizon:
milestone: havana-2 → 2013.2
Changed in keystone:
milestone: havana-2 → 2013.2
Changed in neutron:
milestone: havana-2 → 2013.2
Changed in nova:
milestone: havana-1 → 2013.2
Changed in oslo:
milestone: havana-2 → 2013.2
Changed in trove:
milestone: havana-2 → 2013.2
Thierry Carrez (ttx) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

 affects swift
 status fixreleased
 milestone 1.10.0
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQIcBAEBCAAGBQJSX7ZUAAoJEFB6+JAlsQQjJSQP/2Tg4lNsJI1vh/oclWGjXfkD
bXVwNgBnURGyuRujhcVxNLJKmrp2Eie6T4GkyQJwrIZziZS2Y0GMJX0T1mReCzkF
O8jCe8rlI7ejsJpjFcM7be8tS52DHy51nnIWryUafcomZZYDV42A8qcX/EzsHPlY
Ex/N1RK6uO6zyxf1MmXTyIMU5w/4MZtIRBJMTrQpiWWMPKllfbX9BNJoODKa80oe
Ddlt5sAYKKTfKLHrKr1kP1kCk0119k3LsmXGudbiWJJASqONVuflRrue4XRwjWN6
EbQdP4QHA5fO853AI5NQDbd4Bb3irB0V3pzjkpJiiHgc/eW+VCkvxPVbkk3f7d76
mKQtRlN8zWlFXENAfaMgGoyqUv/M8+spC2WvpxXIXPluhpp13uE+2dQqN+HhGYM3
c1diS05IJ7a42w1dF5JhMc4v6IXbHnTEKMn/rGrWH/QtPMhm3oqt4ofiDu9Bejtk
mFCrkXo0rUoFxGpXjMpA3REPxleFvA28JjkGAxzk8vNOIwPLKGv188l/A+5aL7CZ
yIuVUIYzx4UHdF0GnDpa37WiSVpDx8ZawuIVyO7BGwpSqjd6NE3peByO8saUkYq5
hkPXOxrgH5xvoFy5zMoEADGHhYAkO/PVrZLf1kJ1CKGWF+rhLMdEsDG22flLwFXa
TNBraDsah93E4CB6F4FW
=BI5I
-----END PGP SIGNATURE-----

Thierry Carrez (ttx) wrote : oops

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

 affects swift
 milestone 1.9.0
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQIcBAEBCAAGBQJSX7aWAAoJEFB6+JAlsQQjMEIP/2xV90m9yNmIskOLgqOmR4cr
sgqbNzqexiYLFYrPy7E59v3GiucMGRimgja+WMy0XdDqAgwei3Lb+KtYcuuja+LL
PmtfFuox2FFGXJc9OqAtoNfpkZzmVyMuBOda9jIcksKAE9Z03vHrZhdcKV+ruU/Q
SRVVMlGuNlkeM5KfgiNFMTIPYdQPAjWkJWqAwZ1QbBAEQ+TAWmAxFIv8HtnELKKV
GAUy16+WahGBoyfvd1rUOBz6OB+1nBs5+41bRfFKHuOl9r6epzbgaXu8S7XzEPAX
bzsQnkPNcp4vEnTZRm4XBt/aLUvf4ry76btflFKancqZC/I4ceCVcy8ielGGnr9/
htweptfSkexstHUmIoLk/KFgHGgWaMlxsFaDFQGl3NRoWuS7SEEFbdPKEbQFN5y0
qQGUb8BIbTV6rCgSGAhRRLyPPzJx47+cFNHTTHMx922H1ssTZYdsoP0NmJv+VHzJ
F6dIpLyVl5gBF52Zlmu6hR7LcADedPlujyQGWevEVshW75N7MqPcyLwBPP3vkNed
1t7B95L7uutuihVrMLZOkP5o2KgrtueQOj11p+s/UWchZnwmb0WyXwr9oPCBByRL
TV8o1XeW6cvk0YCh9JR0x19WRbKmUGOQNqv8eJs9ULTGKpzbFoCO25LECUL3Y4Va
xqNDjwGsWEXzrrJiCdZC
=LALU
-----END PGP SIGNATURE-----

Changed in swift:
milestone: 1.9.0 → 1.10.0
milestone: 1.10.0 → 1.9.0
no longer affects: python-heatclient
Éric Araujo (merwok) wrote :

git-review does use requirements.txt and test-requirements.txt. Not sure if it was never affected, or changed without this report being updated, so I’m not changing the status.

Jeremy Stanley (fungi) wrote :

I actually tried to change the status back when it was fixed, but once a Launchpad bug gains enough subscribers (usually by adding too many affected projects, or an unlucky combination of popular ones) it times out on status change attempts both via WebUI and SMTP-based API.

Changed in git-review:
status: New → Fix Committed
importance: Undecided → Medium
no longer affects: heat-cfntools
no longer affects: python-troveclient
Dean Troyer (dtroyer) on 2014-06-20
Changed in python-openstackclient:
importance: Undecided → Low
milestone: none → m2
Jeremy Stanley (fungi) wrote :

Can't seem to set this to fix-released for git-review (even via SMTP API), so commenting here instead.

Michael Still (mikal) on 2014-07-10
Changed in python-novaclient:
milestone: none → 2.18.0
Akihiro Motoki (amotoki) on 2014-08-30
Changed in python-neutronclient:
milestone: 3.0.0 → none
milestone: none → 2.2.1-2.2.6
status: In Progress → Fix Committed
Matthew Treinish (treinish) wrote :

affects tempest
status fixreleased

Jeremy Stanley (fungi) on 2014-10-25
no longer affects: openstack-ci
Michael Still (mikal) on 2015-02-19
Changed in python-novaclient:
milestone: 2.18.0 → 2.21.0
Michael Still (mikal) on 2015-02-19
Changed in python-novaclient:
status: Fix Committed → Fix Released
Akihiro Motoki (amotoki) on 2015-03-03
tags: added: released-neutronclient
no longer affects: tempest
Changed in python-ceilometerclient:
status: Fix Committed → Fix Released
Changed in python-cinderclient:
status: Fix Committed → Fix Released
Changed in python-swiftclient:
status: Fix Committed → Fix Released
Changed in python-glanceclient:
milestone: none → 1.0.0
status: Fix Committed → Fix Released
Changed in python-openstackclient:
status: Fix Committed → Fix Released
Akihiro Motoki (amotoki) on 2015-12-10
Changed in python-neutronclient:
milestone: 2.2.1-2.2.6 → none
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers