Switching projects sends user "home" inappropriately

Bug #1072848 reported by Vinay Bannai on 2012-10-29
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Low
Kieran Spear

Bug Description

I am running a devstack install as of this morning (10/29/2012). I ran into this issue on Ubuntu 12.04 and was logged into the dashboard as "admin:.

On the horizon dashboard, there is the system panel tab on the left side bar. The system panel has two sub-tabs "Project" and "Admin".

When I am in the sub-tab "Project" and switch the project from "admin" to "demo" or "demo" to "admin", I get kicked out of the sub-tab "Project" to "Admin". I am not sure if this by design but it does not seem like this behavior as it is annoying to switch back everytime you switch the project.

I am going to open this bug and let others comment on it.

Gabriel Hurley (gabriel-hurley) wrote :

I noticed a similar behavior. I'm not quite sure what changed that caused that, as it didn't behave that way previously. It is a nuisance, though.

Changed in horizon:
importance: Undecided → Low
milestone: none → grizzly-1
status: New → Confirmed
Justin Shepherd (jshepher) wrote :

Gabriel, we are seeing this behavior also. In addition to this.. if I hava an "Admin" user who has the "Admin" role for 2 tenants ("foo", "bar").. and I switch from the foo project to the bar project.. and click along the tabs under the Project bar.. it will randomly flip between the two projects "foo and bar" even when clicking on the same link (like instances)..

Seeing the same behavior on the Folsom release as well.

Vinay Bannai (vbannai) wrote :

The recent build of horizon seems to have a slightly different look and feel when you log in as admin. I don't see the demo project show up anymore. Was this change intentional? Previously I used to see both admin and demo projects when I logged in as admin.

Changed in horizon:
milestone: grizzly-1 → grizzly-2
Gabriel Hurley (gabriel-hurley) wrote :

The behavior in the original report is actually the result of *fixing* a different bug with the behavior of going to the user's "home" (e.g. default) page after logging in. The problem with the switcher could probably be fixed by appending supplying a "next" redirect value to the auth switcher.

Changed in horizon:
milestone: grizzly-2 → grizzly-3
summary: - Dashboard "System Panel" behavior
+ Switching projects sends user "home" inappropriately
Mohammad Banikazemi (mb-s) wrote :

I see the other problem reported above:

> The recent build of horizon seems to have a slightly different look and feel when you log in as admin. I don't see the demo project show up anymore. Was this change intentional? Previously I used to see both admin and demo projects when I logged in as admin.

I see there were similar bugs in earlier releases which were supposedly fixed but again this has shown up. Very annoying.
Should a new bug be opened with this issue? (This is different from the one reported originally here as the bug description.)

Changed in horizon:
milestone: grizzly-3 → none
Kieran Spear (kspear) on 2013-03-06
Changed in horizon:
assignee: nobody → Kieran Spear (kspear)

Fix proposed to branch: master
Review: https://review.openstack.org/23656

Changed in horizon:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/23656
Committed: http://github.com/openstack/horizon/commit/6db859c849d522fe8d895f2eefd220a5498dc0fd
Submitter: Jenkins
Branch: master

commit 6db859c849d522fe8d895f2eefd220a5498dc0fd
Author: Kieran Spear <email address hidden>
Date: Wed Mar 6 14:37:30 2013 +1100

    Don't change dashboard on admin tenant switch

    Switching projects as an admin user currently dumps you back to
    the Admin dashboard tab. This change fixes that by adding a 'next'
    parameter to the switching URL that points to the default panel
    of the current dashboard.

    The redirect is to the default panel rather than the current one,
    since the next tenant may not have access to the current panel
    and we want to avoid kicking a user back to the login screen.

    Fixes bug #1072848.

    Change-Id: I25b8c0e38945d5db57f5bfe7bb174cdbd66156d5

Changed in horizon:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2013-03-20
Changed in horizon:
milestone: none → grizzly-rc1
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-04-04
Changed in horizon:
milestone: grizzly-rc1 → 2013.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers