Comment 5 for bug 1070083

Gabriel Hurley (gabriel-hurley) wrote :

Cross-posting this from the review:

Modifying the script to use the quantal-only "nodejs" is unacceptable for 2 reasons:

  1. This breaks things for all versions of node which still *do* install a script called "node", including 12.04 which is the LTS.

  2. We're bundling the LESS script *unmodified* from upstream. I'm not open to changing that. The upstream still uses the "node" script name.

Honestly I think this is a problem between the Ubuntu package maintainer for Node and the developers of LESS.

That said, other solution ideas here are welcome.